hdu 1084(水题)

10分钟左右A了...

            What Is Your Grade?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6195    Accepted Submission(s): 1867


Problem Description
“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam! 
Come on!
 
Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.
 
Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
 
Sample Input
4 5 06:30:17 4 07:31:27 4 08:12:12 4 05:23:13 1 5 06:30:17 -1
 
Sample Output
100 90 90 95 100
 
Author
lcy
 
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;

struct node
{
    int key;
    int a,b,c;
    int id,cos;
}g[110];

int cnt[10];

int cmp(node x,node y)
{
    if(x.key!=y.key) return x.key>y.key;
    if(x.a!=y.a) return x.a<y.a;
    if(x.b!=y.b) return x.b<y.b;
    if(x.c!=y.c) return x.c<y.c;
}

int save[110];

int main()
{
    int n;
    while(scanf("%d",&n)&&n>0)
    {
        memset(cnt,0,sizeof(cnt));
        for(int i=0;i<n;i++)
        {
            scanf("%d %d:%d:%d",&g[i].key,&g[i].a,&g[i].b,&g[i].c);
            cnt[g[i].key]++;
            g[i].id=i;
        }
        sort(g,g+n,cmp);
        int tcnt=0;//
        int k=-1;
        for(int i=0;i<n;i++)
        {
            if(g[i].key!=k) 
            {
                k=g[i].key;
                tcnt=1;
            }
            else tcnt++;
            if(g[i].key==0) 
            {
                save[g[i].id]=50;
                continue;
            }
            if(g[i].key==5)
            {
                save[g[i].id]=100;
                continue;
            }
            int tmp=100-10*(5-g[i].key);
            if(tcnt <= cnt[g[i].key]/2) tmp+=5;
            save[g[i].id]=tmp;
        }
        for(int i=0;i<n;i++)
            printf("%d\n",save[i]);
        printf("\n");
    }
    return 0;
}
原文地址:https://www.cnblogs.com/chenhuan001/p/2951180.html