2015 HUAS Summer Trainning #6~G

Description

There is a hill with n holes around. The holes are signed from 0 to n-1. 



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes. 
 

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648). 
 

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line. 
 

Sample Input

2
1 2
2 2
 

Sample Output

NO
YES
解题思路:题目的意思是求两个数的最大公约数,如果最大公约数是1,那就输出NO,否则输出YES。这个题目没什么技巧,用一个while循环差不多就可以解决。
程序代码:
#include<stdio.h>
int F(int m,int n)
{
 int t;
 while(n%=m)//,n)
  t=m,m=n,n=t;
 return m;
}
int main()
{
 int m,n,k,t;
 scanf("%d",&t);
 while(t--)
 {
  scanf("%d%d",&m,&n);
  k=F(m,n);
  if(k==1)
   printf("NO ");
  else
   printf("%YES ");
 }
 return 0;
}
原文地址:https://www.cnblogs.com/chenchunhui/p/4736992.html