HUAS Summer Trainning #3~B

Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: ‘Case #M: The maximum product is P.’, where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input

3

2 4 -3

5

2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8.

Case #2: The maximum product is 20.

解题思路:此题是要求最大乘积,但是输入的数字有正有负,当输入的数中的负数的个数是偶数时,最大的乘积就是每一个数相乘之后的积,但是当个数为奇数时就要注意,最大乘积可能在前面可能在后面也可能在中间。要把每一个可能都考虑进来。

程序代码:

#include <iostream>
using namespace std;
int a[22];
int main()
{
	int n,v=0;
	long t;
	while(cin>>n&&n)
	{
		v++;
		long min=0;
		for(int i=0;i<n;i++)
			cin>>a[i];
		for(int k=0;k<n;k++)
		{
		    t=1;
			for(int j=k;j<n;j++)
			{
				t=t*a[j];
				if(t>min)
					min=t;
			}
		}
		cout<<"Case #"<<v<<": The maximum product is "<<min<<"."<<endl<<endl;

	}
	return 0;

}
原文地址:https://www.cnblogs.com/chenchunhui/p/4688232.html