P2872 [USACO07DEC]道路建设Building Roads

https://www.luogu.org/problem/show?pid=2872

 

题目描述

Farmer John had just acquired several new farms! He wants to connect the farms with roads so that he can travel from any farm to any other farm via a sequence of roads; roads already connect some of the farms.

Each of the N (1 ≤ N ≤ 1,000) farms (conveniently numbered 1..N) is represented by a position (Xi, Yi) on the plane (0 ≤ Xi ≤ 1,000,000; 0 ≤ Yi ≤ 1,000,000). Given the preexisting M roads (1 ≤ M ≤ 1,000) as pairs of connected farms, help Farmer John determine the smallest length of additional roads he must build to connect all his farms.

给出nn个点的坐标,其中一些点已经连通,现在要把所有点连通,求修路的最小长度.

输入输出格式

输入格式:

  • Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: Two space-separated integers: Xi and Yi

  • Lines N+2..N+M+2: Two space-separated integers: i and j, indicating that there is already a road connecting the farm i and farm j.

输出格式:

  • Line 1: Smallest length of additional roads required to connect all farms, printed without rounding to two decimal places. Be sure to calculate distances as 64-bit floating point numbers.

输入输出样例

输入样例#1:
4 1
1 1
3 1
2 3
4 3
1 4
输出样例#1:
4.00

#include<bits/stdc++.h>
using namespace std;
#define maxn 10000000
int n,m,s,t,a,b,z,fa[maxn],head[maxn],dis[maxn],cnt,tot,x[maxn],y[maxn];
double ans;
struct Edge{
    int x,y;
    double w;
}edge[maxn];
bool cmp(Edge a,Edge b) { return a.w<b.w; }
int find(int x){ return fa[x]==x?x:fa[x]=find(fa[x]); }
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
        scanf("%d%d",&x[i],&y[i]);
    for(int i=1;i<=n;i++) fa[i]=i;
    for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++)
        {
            edge[++cnt].x=i;
            edge[cnt].y=j;
            edge[cnt].w=sqrt((double)(x[i]-x[j])*(double)(x[i]-x[j])+(double)(y[i]-y[j])*(double)(y[i]-y[j]));
        }
    sort(edge+1,edge+cnt+1,cmp);
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d",&a,&b);
        fa[find(a)]=find(b);
    }
    for(int i=1;i<=cnt;i++)
    {
        int fx=find(edge[i].x),fy=find(edge[i].y);
        if(fx!=fy)
        {
            ans+=edge[i].w;
            fa[fx]=fy;
            tot++;
        }
        
        if(tot==n-1) break;
    }
    printf("%.2lf",ans);
    return 0;
}
原文地址:https://www.cnblogs.com/chen74123/p/7416512.html