1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N1 aN1 N2 aN2 ... NK aNK

where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1K10, 0NK<<N2<N11000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

Submit:

#include <iostream>
#include <cmath>
using namespace std;
//目标:求多项式的乘积
int main() {
    int a,b,i,j,exp,k=0;
    scanf("%d",&a);
    float coe,arr[1001]={0.0},temp[2001]={0.0};//相乘后指数最大为2000
    for (i=0;i<a;i++) {
        scanf("%d %f",&exp,&coe);
        arr[exp] = coe;
    }
    scanf("%d",&b);
    for (i=0; i<b; i++) {
        scanf("%d %f",&exp,&coe);
        for (j=0;j<1001;j++) //遍历第一行所有系数
            if (arr[j] != 0.0) temp[exp+j] += coe*arr[j];//把第二行输入的每一个系数与第一行每一个相乘 结果保存到temp数组 +=保存相同系数的和
    }
    for (i=0;i<2001;i++) 
        if (temp[i] != 0.0) k++;
    printf("%d",k);
    for (i=2001;i>=0;i--) 
        if (temp[i] != 0.0) printf(" %d %.1f",i,temp[i]);
    return 0;
}
原文地址:https://www.cnblogs.com/cgy-home/p/15119792.html