Mobile phones(二维树状数组)

Mobile phones

Description:
Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.
Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.
Input:
The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.
The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.
Table size:
1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30
Output:
Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.
Sample Input:
0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3
Sample Output:
3
4
题目大意:
给出一个全0的矩阵,然后一些操作
0 S:初始化矩阵,维数是S*S,值全为0,这个操作只有最开始出现一次
1 X Y A:对于矩阵的X,Y坐标增加A
2 L B R T:询问(L,B)到(R,T)区间内值的总和
{l、b为左上角,r、t为右下角}
3:结束对这个矩阵的操作

#include<iostream>
#include<cstring>
using namespace std;
const int maxx=1025;
int n,tmp,ans,map[maxx][maxx],c[maxx][maxx];
int lowbit(int x)
{
    return x&-x;
}
void modify(int x,int y,int add)
{
    for(int i=x;i<=n;i+=lowbit(i))
      for(int j=y;j<=n;j+=lowbit(j))
      c[i][j]+=add;
}
int pre_sum(int x,int y)
{
    int num=0;
    for(int i=x;i>0;i-=lowbit(i))
      for(int j=y;j>0;j-=lowbit(j))
      num+=c[i][j];
    return num;
}
int sum(int x1,int y1,int x2,int y2)
{
    int num=0;
    num=pre_sum(x2,y2)-pre_sum(x1-1,y2)-pre_sum(x2,y1-1)+pre_sum(x1-1,y1-1);
    return num;
}
int main()
{
    int x1,y1,x2,y2,add;
    while(1)
    {
        cin>>tmp;
        if(tmp==0)
        {
            cin>>n;
            memset(c,0,sizeof(c));
        }
        if(tmp==1)
        {
            cin>>x1>>y1>>add;
            modify(x1+1,y1+1,add);
        }
        if(tmp==2)
        {
            cin>>x1>>y1>>x2>>y2;
            ans=sum(x1+1,y1+1,x2+1,y2+1);
            cout<<ans<<endl;
        }
        if(tmp==3)
        return 0;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/cax1165/p/6070987.html