shopping(多次spfa求局部最短路)

Shopping

Problem Description
You have just moved into a new apartment and have a long list of items you need to buy. Unfortunately, to buy this many items requires going to many different stores. You would like to minimize the amount of driving necessary to buy all the items you need.
Your city is organized as a set of intersections connected by roads. Your house and every store is located at some intersection. Your task is to find the shortest route that begins at your house, visits all the stores that you need to shop at, and returns to your house.
Input
The first line of input contains a single integer, the number of test cases to follow. Each test case begins with a line containing two integers N and M, the number of intersections and roads in the city, respectively. Each of these integers is between 1 and 100000, inclusive. The intersections are numbered from 0 to N-1. Your house is at the intersection numbered 0. M lines follow, each containing three integers X, Y, and D, indicating that the intersections X and Y are connected by a bidirectional road of length D. The following line contains a single integer S, the number of stores you need to visit, which is between 1 and ten, inclusive. The subsequent S lines each contain one integer indicating the intersection at which each store is located. It is possible to reach all of the stores from your house.
Output
For each test case, output a line containing a single integer, the length of the shortest possible shopping trip from your house, visiting all the stores, and returning to your house.
Sample Input
1
4 6
0 1 1
1 2 1
2 3 1
3 0 1
0 2 5
1 3 5
3
1
2
3
Sample Output
4
题目大意:
给你一个无向图,求从0号点开始遍历所有的指定点再回到0号点的最短路径
思路:
要求从0点开始,遍历所有指定点,然后回到0点,如果以0为起点,跑spfa,求出的是每个点到0点的距离,同样的思路,以指定的每个点为起点,用spfa求出,每个指定点之间的最短路,最后求和,即为答案。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn=200010;
int t,n,m,k,tot,dis[maxn],head[maxn],a[maxn],c[maxn],g[20][20];
bool flag[maxn];
struct  node
{
    int to;
    int w;
    int next;
}e[maxn*10];
void add_edge(int u,int v,int w)
{
    e[++tot].to=v;
    e[tot].w=w;
    e[tot].next=head[u];
    head[u]=tot;
}
void spfa(int u)
{
    memset(dis,127/3,sizeof(dis));
    memset(flag,0,sizeof(flag));
    dis[u]=0;queue<int> q;
    q.push(u);flag[u]=1;
    while(!q.empty())
    {
        u=q.front();
        q.pop();flag[u]=0;
        for(int i=head[u];i;i=e[i].next)
        {
            int v=e[i].to;
            if(dis[v]>dis[u]+e[i].w)
            {
                dis[v]=dis[u]+e[i].w;
                if(!flag[v])
                {
                    q.push(v);
                    flag[v]=1;
                }
            }
        }
    }
}
int main()
{
    int x,y,z;
    scanf("%d",&t);
    while(t--)
    {
        memset(head,0,sizeof(head));
        memset(g,127/3,sizeof(g));
        memset(c,0,sizeof(c));
        memset(a,0,sizeof(a));
        tot=0;long long ans=0x7fffffff;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            add_edge(x,y,z);
            add_edge(y,x,z);
        }
        scanf("%d",&k);
        for(int i=1;i<=k;i++)
        scanf("%d",&c[i]),a[i]=i;
        spfa(0);
        for(int i=1;i<=k;i++)
        g[0][i]=g[i][0]=dis[c[i]];
        for(int i=1;i<=k;i++)
        {
            spfa(c[i]);
            for(int j=1;j<=k;j++)
            g[i][j]=dis[c[j]];
        }
        do
        {
            long long tmp=0;
            for(int i=1;i<=k+1;i++)
            tmp+=g[a[i-1]][a[i]];
            ans=min(ans,tmp);
        }while(next_permutation(a+1,a+k+1));
        cout<<ans<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/cax1165/p/6070864.html