Jungle Roads

Jungle Roads 
 
 
The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30


我要开始我的表演了,balabalabala
题意:
A 2 B 12 I 25  这个意思是和A相连的有两个点,一个是B一个是I,其中A----12-----B   A------25-------I
好了,就是这样,用prim就得用数组三兄弟。这个时候就要好好想想该怎么把这些关系存到数组里了,

如何存到数组里:(给你个思路)
for (int i = 0; i < n - 1; i++)
        {
            char ch;
            int num;
            cin >> ch >> num;
            for (int j = 0; j < num; j++)
            {
                char name;
                int figure;
                cin >> name >> figure;
                map[ch - 'A'][name - 'A'] = map[name - 'A'][ch - 'A'] = figure;
            }
        }
好了,AC代码:(其实这个代码和思路是从同学那里得来的,在这里要鸣谢一下)
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int inf = 100000000;
int map[105][105];
int vis[105];
bool used[105];
int n;
int prim()
{
    for (int i = 0; i < n; i++)
    {
        vis[i] = inf;
        used[i] = false;
    }
    vis[0] = 0;
    int res = 0;
    while (true)
    {
        int u = -1;
        for (int i = 0; i < n; i++)
        {
            if (!used[i] && (u == -1 || vis[i] < vis[u]))
                u = i;
        }
        if (u == -1)
            break;
        used[u] = true;
        res += vis[u];
        for (int j = 0; j < n; j++)
        {
            vis[j] = min(vis[j], map[u][j]);
        }
    }
    return res;
}
int main()
{
    while (cin >> n, n)
    {
        for (int i = 0; i < n; i++)
        {
            for (int j = 0; j < n; j++)
                map[i][j] = inf;
        }
        for (int i = 0; i < n - 1; i++)
        {
            char ch;
            int num;
            cin >> ch >> num;
            for (int j = 0; j < num; j++)
            {
                char name;
                int figure;
                cin >> name >> figure;
                map[ch - 'A'][name - 'A'] = map[name - 'A'][ch - 'A'] = figure;
            }
        }
        cout << prim() << endl;
    }
    return 0;
}
good luck!今天也是元气满满的一天。
我想要变得高一点,最好能伸手给你一片天。
原文地址:https://www.cnblogs.com/cattree/p/7405591.html