Octal Fractions (高精度) (java)

Fractions in octal (base 8) notation can be expressed exactly in decimal notation. For example, 0.75 in octal is 0.953125 (7/8 + 5/64) in decimal. All octal numbers of n digits to the right of the octal point can be expressed in no more than 3n decimal digits to the right of the decimal point.

Write a program to convert octal numerals between 0 and 1, inclusive, into equivalent decimal numerals.

Input

The input to your program will consist of octal numbers, one per line, to be converted. Each input number has the form 0.d1d2d3 ... dk, where the di are octal digits (0..7). There is no limit on k.

Output

Your output will consist of a sequence of lines of the form

0.d1d2d3 ... dk [8] = 0.D1D2D3 ... Dm [10]



where the left side is the input (in octal), and the right hand side the decimal (base 10) equivalent. There must be no trailing zeros, i.e. Dm is not equal to 0.

Sample Input

0.75
0.0001
0.01234567

Sample Output

0.75 [8] = 0.953125 [10]
0.0001 [8] = 0.000244140625 [10]
0.01234567 [8] = 0.020408093929290771484375 [10]

输入一个8进制小数 输出十进制小数

要是有c需要手写高精加法

所以java有时很有优势

import java.math.BigDecimal;
import java.util.*;
import java.math.*;
import java.io.*;


public class Main {
	public static void main(String ards[])
	{
		String s;
		BigDecimal num8= new BigDecimal(8);
		Scanner cin = new Scanner(System.in);  //必须要写
		while(cin.hasNext())//循环输入格式
		{
			s=cin.nextLine();//读入字符串
			BigDecimal temp = new BigDecimal(1);//定义常数 要new
			BigDecimal ans=  new BigDecimal(0);
			for(int i=2;i<s.length();i++)
			{
				temp=temp.divide(num8);
				ans=ans.add(new BigDecimal(s.charAt(i)-'0').multiply(temp));//大数要使用函数进行运算
			}
			//0.75 [8] = 0.953125 [10]
			System.out.println(s+" [8] = "+ans+" [10]");
		}
	}

}
原文地址:https://www.cnblogs.com/caowenbo/p/11852222.html