洛谷 P4181 [USACO18JAN]Rental Service

题意翻译

farmer john有N(1≤N≤100,000)头牛,他想赚跟多的钱,所以他准备买牛奶和出租牛。有M(1≤M≤100,000 )家商店想买牛奶,每家商店的进货价不同。有R(1≤R≤100,000 )户邻居想租牛,每户人家的租价不同。 问他最多能赚多少钱。

输入:输入的第1行包含n,m,r三个整数。紧接着的n行每一行有1个整数Ci (1≤Ci≤1,000,000),表示第i头牛产出Ci加仑奶。再下面的m行每行有两个整数Qi与Pi (1≤Qi,Pi≤1,000,000),表示第i个商店最多以Pi美分每加仑的价格购买Qi加仑牛奶。FJ可销售0~Qi加仑牛奶到一个商店。然后的r行每行有一个整数Ri,表示FJ的第i个邻居想以Ri(1≤Ri≤1,000,000 ), 的价格租一头牛。

输出:仅一行。表示一天最多获得多少钱。

注意:int类型不够大!!!

说明: FJ 需要挤一号和四号奶牛的奶,共可得牛奶13加仑。他可以先买给出价最高的10加仑,赚250美分,然后把剩下的按每加仑15美分去卖,共有295美分的利润。 然后,他要把其他三头以250,80,和100美分的价格分别卖出,赚430美分。所以他一共可得725美分/日的利润。

---by 风格雨关、WuYongxuan、毕沁露

题目描述

Farmer John realizes that the income he receives from milk production is insufficient to fund the growth of his farm, so to earn some extra money, he launches a cow-rental service, which he calls "USACOW" (pronounced "Use-a-cow").

Farmer John has NN cows (1 leq N leq 100,0001N100,000), each capable of producing some amount of milk every day. The MMstores near FJ's farm (1 leq M leq 100,0001M100,000) each offer to buy a certain amount of milk at a certain price. Moreover, Farmer John's RR (1 leq R leq 100,0001R100,000) neighboring farmers are each interested in renting a cow at a certain price.

Farmer John has to choose whether each cow should be milked or rented to a nearby farmer. Help him find the maximum amount of money he can make per day.

输入输出格式

输入格式:

 

The first line in the input contains NN, MM, and RR. The next NN lines each contain an integer c_ici (1 leq c_i leq 1,000,0001ci1,000,000), indicating that Farmer John's iith cow can produce c_ici gallons of milk every day. The next MMlines each contain two integers q_iqi and p_ipi (1 leq q_i, p_i leq 1,000,0001qi,pi1,000,000), indicating that the iith store is willing to buy up to q_iqi gallons of milk for p_ipi cents per gallon. Keep in mind that Farmer John can sell any amount of milk between zero and q_iqi gallons to a given store. The next RR lines each contain an integer r_iri (1 leq r_i leq 1,000,0001ri1,000,000), indicating that one of Farmer John's neighbors wants to rent a cow for r_iri cents per day.

 

输出格式:

 

The output should consist of one line containing the maximum profit Farmer John can make per day by milking or renting out each of his cows. Note that the output might be too large to fit into a standard 32-bit integer, so you may need to use a larger integer type like a "long long" in C/C++.

 

输入输出样例

输入样例#1: 复制
5 3 4
6
2
4
7
1
10 25
2 10
15 15
250
80
100
40
输出样例#1: 复制
725

说明

Farmer John should milk cows #1 and #4, to produce 13 gallons of milk. He should completely fill the order for 10 gallons, earning 250 cents, and sell the remaining three gallons at 15 cents each, for a total of 295 cents of milk profits.

Then, he should rent out the other three cows for 250, 80, and 100 cents, to earn 430 more cents. (He should leave the request for a 40-cent rental unfilled.) This is a total of 725 cents of daily profit.

#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef pair<int, int>P;
typedef long long ll;
const int MAXN=1e5+20;
P shop;
int N,M,R;
int buy[MAXN],cow[MAXN];
priority_queue<P> q;
int main(){
    cin>>N>>M>>R;
    for(int i=1;i<=N;i++) scanf("%d",&cow[i]);
    for(int i=1;i<=M;i++){
        scanf("%d%d",&shop.second,&shop.first);
        q.push(shop);
    }
    for(int i=1;i<=R;i++)scanf("%d",&buy[i]);
    sort(cow+1,cow+N+1);
    sort(buy+1,buy+R+1);
    int l=1,r=N,b=R;
    ll ans=0,tmp=-1; 
    for(int i=1;i<=N;i++){
        if(tmp==-1)
            while(!q.empty()&&cow[r]){
                if(tmp==-1) tmp=0;
                if(q.top().second>cow[r]) {
                    P p=q.top();q.pop();
                    tmp+=1LL*cow[r]*p.first,
                    p.second-=cow[r],cow[r]=0;
                    q.push(p);
                }
                else 
                    tmp+= 1LL*q.top().first*q.top().second,
                    cow[r]-=q.top().second, q.pop();
            } 
        if(tmp!=-1&&tmp>=buy[b])
            ans+=tmp,tmp=-1,--r;
        else if(b!=0) ans+=buy[b--],++l;
    }
    cout<<ans<<endl;
    return 0;
}
原文地址:https://www.cnblogs.com/cangT-Tlan/p/9723698.html