CF899A Splitting in Teams

题意翻译

n个数,只有1,2,把它们任意分组,和为3的组最多多少

题目描述

There were nn groups of students which came to write a training contest. A group is either one person who can write the contest with anyone else, or two people who want to write the contest in the same team.

The coach decided to form teams of exactly three people for this training. Determine the maximum number of teams of three people he can form. It is possible that he can't use all groups to form teams. For groups of two, either both students should write the contest, or both should not. If two students from a group of two will write the contest, they should be in the same team.

输入输出格式

输入格式:

 

The first line contains single integer nn ( 2<=n<=2·10^{5}2<=n<=2105 ) — the number of groups.

The second line contains a sequence of integers a_{1},a_{2},...,a_{n}a1,a2,...,an ( 1<=a_{i}<=21<=ai<=2 ), where a_{i}ai is the number of people in group ii .

 

输出格式:

 

Print the maximum number of teams of three people the coach can form.

 

输入输出样例

输入样例#1: 复制
4
1 1 2 1
输出样例#1: 复制
1
输入样例#2: 复制
2
2 2
输出样例#2: 复制
0
输入样例#3: 复制
7
2 2 2 1 1 1 1
输出样例#3: 复制
3
输入样例#4: 复制
3
1 1 1
输出样例#4: 复制
1

说明

In the first example the coach can form one team. For example, he can take students from the first, second and fourth groups.

In the second example he can't make a single team.

In the third example the coach can form three teams. For example, he can do this in the following way:

  • The first group (of two people) and the seventh group (of one person),
  • The second group (of two people) and the sixth group (of one person),
  • The third group (of two people) and the fourth group (of one person).
  • #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int n,ans,sum1,sum2;
    int main(){
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            int x;scanf("%d",&x);
            if(x==1)    sum1++;
            if(x==2)    sum2++;
        }
        ans+=min(sum1,sum2);sum1-=ans,sum2-=ans;
        ans+=sum1/3;
        cout<<ans;
    }
细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
原文地址:https://www.cnblogs.com/cangT-Tlan/p/8440816.html