P2899 [USACO08JAN]手机网络Cell Phone Network

Farmer John has decided to give each of his cows a cell phone in hopes to encourage their social interaction. This, however, requires him to set up cell phone towers on his N (1 ≤ N ≤ 10,000) pastures (conveniently numbered 1..N) so they can all communicate.

Exactly N-1 pairs of pastures are adjacent, and for any two pastures A and B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B) there is a sequence of adjacent pastures such that A is the first pasture in the sequence and B is the last. Farmer John can only place cell phone towers in the pastures, and each tower has enough range to provide service to the pasture it is on and all pastures adjacent to the pasture with the cell tower.

Help him determine the minimum number of towers he must install to provide cell phone service to each pasture.

John想让他的所有牛用上手机以便相互交流(也是醉了。。。),他需要建立几座信号塔在N块草地中。已知与信号塔相邻的草地能收到信号。给你N-1个草地(A,B)的相邻关系,问:最少需要建多少个信号塔能实现所有草地都有信号。

输入输出格式

输入格式:

 

  • Line 1: A single integer: N

  • Lines 2..N: Each line specifies a pair of adjacent pastures with two space-separated integers: A and B

 

输出格式:

 

  • Line 1: A single integer indicating the minimum number of towers to install

 

输入输出样例

输入样例#1:
5
1 3
5 2
4 3
3 5
输出样例#1:
2
思路:经典的树上最小支配集。

 判断树的最小支配集,条件如下  

1、选一结点为根后序遍历  

2、遍历过程中,如果该结点没被覆盖,该结点的父亲结点没被覆盖,且该结点的子结点中没有被覆盖的,则该结点的父亲结点即为一覆盖点 

#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAXN 10010
using namespace std;
int n,ans;
int vis[MAXN],over[MAXN];
vector<int>vec[MAXN];
void dfs(int fa,int now){
    vis[now]=1;
    bool flag=false;
    for(int i=0;i<vec[now].size();i++)
        if(!vis[vec[now][i]]){
            dfs(now,vec[now][i]);
            flag=flag||over[vec[now][i]];
        }
    if(!over[fa]&&!flag&&!over[now]){
        over[fa]=1;
        ans++;
    }
}
int main(){
    scanf("%d",&n);
    for(int i=1;i<n;i++){
        int u,v;
        scanf("%d%d",&u,&v);
        vec[u].push_back(v);
        vec[v].push_back(u);
    }
    dfs(0,1);
    cout<<ans;
}
 
细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
原文地址:https://www.cnblogs.com/cangT-Tlan/p/7638896.html