UVA 116 Unidirectional TSP

  Unidirectional TSP

  Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) — finding whether all the cities in a salesperson’s route can be visited exactly once with a specified limit on travel time — is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check.

  This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

  Given an m×n matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i + 1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix “wraps” so that it represents a horizontal cylinder. Legal steps are illustrated on the right.

  The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited. For example, two slightly different 5×6 matrices are shown below (the only difference is the numbers in the bottom row).

Input

  The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

Input The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by m · n integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive.

Output

  Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

Note: Lexicographically means the natural order on sequences induced by the order on their elements.

Sample Input


5 6

3 4 1 2 8 6

6 1 8 2 7 4

5 9 3 9 9 5

8 4 1 3 2 6

3 7 2 8 6 4

5 6

3 4 1 2 8 6

6 1 8 2 7 4

5 9 3 9 9 5

8 4 1 3 2 6

3 7 2 1 2 3

2 2

9 10

9 10

Sample Output

1 2 3 4 4 5 16 1 2 1 5 4 5 11 1 1 19

题意:有一个m行n列的整数矩阵,从第一列任何一个位置出发每次向右,右上,右下走一格。要求经过的整数值和最小,整个矩阵是环形的,即第一行的上一行是最后一行,最后一行的下一行是第一行。输出滤镜上梅雷的编号,多解时,输出字典序最小的。

思路:类似于数字三角形,需要倒推。具体实现见代码。

吐槽:我好菜,我好菜,我是机房第一菜。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,dis[11][110],f[11][110],net[11][110];
int main(){
    while(scanf("%d%d",&m,&n)!=EOF){
        memset(f,0,sizeof(f));
        memset(dis,0,sizeof(dis));
        memset(net,0,sizeof(net)); 
        for(int i=1;i<=m;i++)
            for(int j=1;j<=n;j++)
                scanf("%d",&dis[i][j]);
        int ans=0x7f7f7f7f,first=0;
        for(int j=n;j>=1;j--)
            for(int i=1;i<=m;i++){
                if(j==n)    f[i][j]=dis[i][j];
                else{
                    int rows[3]={i,i-1,i+1}; //直走,向左上,向右下。 
                    if(i==1)    rows[1]=m;//如果是第一行,去最后一行 
                    if(i==m)    rows[2]=1;//如果走到最后一行,绕回第一行。 
                    sort(rows,rows+3);        //排序,找字典序最小。
                    f[i][j]=0x7f7f7f7f;
                    for(int k=0;k<3;k++){
                        if(f[rows[k]][j+1]+dis[i][j]<f[i][j]){
                            f[i][j]=f[rows[k]][j+1]+dis[i][j];
                            net[i][j]=rows[k];//记录路径 
                        }
                    } 
                }
                if(j==1&&f[i][j]<ans){
                    ans=f[i][j];
                    first=i;
                }
            }
        printf("%d",first);
        for(int i=net[first][1],j=2;j<=n;i=net[i][j],j++)
            printf(" %d",i);
        printf("
%d
",ans);
    }
}
细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
原文地址:https://www.cnblogs.com/cangT-Tlan/p/7433776.html