proj 1007

proj 1007:

DNA Sorting
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 76307   Accepted: 30599

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source

 
accepted:
 
#include<iostream>
#include<string>
using namespace std;

int measure(char *s){
	int len = strlen(s);
	int A = 0;
	int C = 0;
	int G = 0;
	int T = 0;
	int value = 0;
	for(int i = len - 1; i >= 0; --i){
		if(s[i] == 'A'){
			++A;
		}
		if(s[i] == 'C'){
			value = value + A;
			++C;
		}
		if(s[i] == 'G'){
			value = value + A + C;
			++G;
		}
		if(s[i] == 'T'){
			value = value + A + C + G;
		}
		//cout<<i<<":"<<value<<endl;
	}
	return value;
}

void special_qsort(int *a, int i, int j, int *b){
	if(i < j){
		int flag = i;
		for(int k = i + 1; k < j + 1; ++k){
			if(a[k] <= a[i]){
				++flag;
				int temp1 = a[k];
				int temp2 = b[k];
				a[k] = a[flag];
				b[k] = b[flag];
				a[flag] = temp1;
				b[flag] = temp2;
			}
		}
		int temp1 = a[i];
		int temp2 = b[i];
		a[i] = a[flag];
		b[i] = b[flag];
		a[flag] = temp1;
		b[flag] = temp2;
		special_qsort(a, i, flag - 1, b);
		special_qsort(a, flag + 1, j, b);
	}
}


int main()
{

	int n,m;
	cin>>n>>m;
	int *b = new int[m];
	for(int i = 0; i < m; ++i){
		b[i] = i;
	}


	char *p = new char[n*m];
	char *p1 = new char[n];
	int *a = new int[m];
	int i = 0;
	while(i < m){
		cin>>p1;
		a[i] = measure(p1);
		for(int j = i*n; j < (i + 1)*n; ++j){
			p[j] = p1[j - i*n];
		}
		++i;
	}
	p[n*m] = '';

	special_qsort(a, 0, m - 1, b);
	int t = 0;
	while(t < m){
		for(int j = n*b[t]; j < (b[t] + 1)*n; ++j){
			cout<<p[j];
		}
		cout<<endl;
		++t;
	}
	return 0;
}


Maya Calendar

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 61272   Accepted: 18901

Description


During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor. 

For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles. 

Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows: 

1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . . 

Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was: 

Haab: 0. pop 0 

Tzolkin: 1 imix 0 
Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar. 

Input


The date in Haab is given in the following format: 
NumberOfTheDay. Month Year 

The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000. 

Output


The date in Tzolkin should be in the following format: 
Number NameOfTheDay Year 

The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates. 

Sample Input


3
10. zac 0
0. pop 0
10. zac 1995

Sample Output


3
3 chuen 0
1 imix 0
9 cimi 2801

Source





#include<iostream>
#include<string>
#include<string.h>
using namespace std;


bool equal(char *s1, char *s2){
	int i = 0;
	while((s1[i] == s2[i])&& (s1[i] != '')){
		++i;
	}
	if((s1[i] == '')&& (s2[i] == '')){
		return true;
	}else{
		return false;
	}
}

structnode{
	int year;
	int month;
	int day;
	node(int i = 0, int j = 0, int k = 0){
		year = i;
		month = j;
		day = k;
	}
};

int days(int day, char *month, int year){
	char *s[] = {"pop", "no", "zip", "zotz", "tzec", "xul", "yoxkin", "mol", "chen", "yax", "zac", "ceh", "mac", "kankin", "muan", "pax", "koyab", "cumhu","uayet"};
	int m = 0;
	while(!equal(month, s[m])){
		++m;
	}
	int days = m*20 + day + 365*year + 1;

	return days;
}

node print(int days){
	int year = days/260;
	int flag = 0;
	if(year*260 == days){
		year = year - 1;
		flag = 1;
	}
	int day;
	int num;
	if(flag){
		day = 19;
		num = 13;
	}else{
		day = ((days - 260*year)%20 - 1);
		num = (days - 260*year)%13;
	}

	if(num == 0){
		num = 13;
	}
	node p;
	p.day  = num;
	p.year = year;
	p.month = day;
	return p;
}

int main(){
	char *s[] = {"imix", "ik", "akbal", "kan", "chicchan", "cimi", "manik", "lamat", "muluk", "ok", "chuen", "eb", "ben", "ix", "mem", "cib", "caban", "eznab", "canac", "ahau"};
	int n;
	cin>>n;
	node *pt = new node[n];
	int year;
	string day;
	string month;
	int temp;
	int num;

	for(int k = 0; k < n; ++k){
		cin>>day;
		int m = day.size();
		if(m == 3)temp = 10*(day[0] - '0') + (day[1] - '0');
		if(m == 2)temp = (day[0] - '0');
		cin>>month;
		cin>>year;

		char *p = new char[month.size()];
		for(int i = 0; i < month.size(); ++i){
			p[i] = month[i];
		}
		p[month.size()] = '';
		pt[k] = print(days(temp,p,year));
	}
    cout<<n<<endl;
	for(int i = 0; i < n; ++i){
		cout<<pt[i].day<<" "<<s[pt[i].month]<<" "<<pt[i].year<<endl;
	}
	return 0;
}
原文地址:https://www.cnblogs.com/candycloud/p/3390910.html