POJ2828 Buy Tickets[树状数组第k小值 倒序]

Buy Tickets
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 19012   Accepted: 9442

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

Source


题意:n个人,插队位置pi之后,价值vi,求结束后价值序列

考虑最后一个人一定在p[n]+1位置,第n-1个人在第p[n-1]+1位置(第n个人不算占用位置)
倒序处理,每个人的位置就是当前的p[i]+1小值,同时要删除这个人
用树状数组实现动态求k小值和删除
 
WARN:
二进制从16开始小了,从18开始  2^18=262144
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
typedef long long ll;
const int N=2e5+5;
inline int read(){
    char c=getchar();int x=0,f=1;
    while(c<'0'||c>'9'){if(c=='-')f=-1;c=getchar();}
    while(c>='0'&&c<='9'){x=x*10+c-'0';c=getchar();}
    return x*f;
}

int n,ans[N];
struct people{
    int p,v;
}a[N];
int c[N];
inline int lowbit(int x){return x&-x;}
inline void build(){
    //memset(c,0,sizeof(c));
    for(int i=1;i<=n;i++){
        c[i]++;
        if(i+lowbit(i)<=n) c[i+lowbit(i)]+=c[i];
    }
}
inline void add(int p,int v){
    for(;p<=n;p+=lowbit(p)) c[p]+=v;
}
inline int kth(int k){
    int x=0,cnt=0;
    for(int i=18;i>=0;i--){
        x+=(1<<i);
        if(x>=n||cnt+c[x]>=k) x-=(1<<i);
        else cnt+=c[x];
    }
    return x+1;
}
int main(){
    while(scanf("%d",&n)!=EOF){
        for(int i=1;i<=n;i++) a[i].p=read(),a[i].v=read();
        build();
        for(int i=n;i>=1;i--){
            int pos=kth(a[i].p+1);
            ans[pos]=a[i].v;
            add(pos,-1);
        }
        for(int i=1;i<=n;i++) printf("%d%c",ans[i],i==n?'
':' ');
    }
}
 
原文地址:https://www.cnblogs.com/candy99/p/6069035.html