POJ3187Backward Digit Sums[杨辉三角]

Backward Digit Sums
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6350   Accepted: 3673

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

4 3 6
7 9
16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

Source


全排列中的数字对sum贡献的次数就是杨辉三角第n-1列
杨辉三角是从0开始
组合数公式递推
dfs+剪枝
//
//  main.cpp
//  poj3187
//
//  Created by Candy on 9/12/16.
//  Copyright © 2016 Candy. All rights reserved.
//

#include <iostream>
#include <cstdio>
using namespace std;
const int N=15;
int n,sum,c[N],vis[N],ans[N],flag=0;
void dfs(int d,int now){
    if(flag) return;
    if(d==n&&now==sum) {flag=1;for(int i=0;i<n;i++) printf("%d ",ans[i]);return;}
    if(d==n) return;
    for(int i=1;i<=n;i++){
        if(vis[i]) continue;
        if(now+i*c[d]<=sum){
            ans[d]=i; vis[i]=1;
            dfs(d+1,now+i*c[d]);
            vis[i]=0;
        }
    }
}
int main(int argc, const char * argv[]) {
    scanf("%d%d",&n,&sum);
    n--;
    c[0]=1;
    for(int i=1;i<=n;i++) c[i]=c[i-1]*(n-i+1)/i;
    n++;
    dfs(0,0);
    return 0;
}
原文地址:https://www.cnblogs.com/candy99/p/5866965.html