PAT 甲级 1056 Mice and Rice (25 分) (队列,读不懂题,读懂了一遍过)

1056 Mice and Rice (25 分)
 

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (,) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

分组比赛,注意以下几点

1.先考虑一下rank怎么来的,假设某次比赛有m人,每组为ng人,不难确定,可以分为group组(group为(m/ng)向上取整),就是说有group个赢家,剩下的人的排名自然就都是group+1;(这里卡了一下,不会算rank)

2.从前往后,每ng为一组,每组的最重者有形成一个新的序列,用队列最方便。(在看题目的时候没有想到队列)

3.initial playing order与输入的order之间的关系:输入的order是我们分组用的order,其实在比赛过程中,我们不用管initial playing order的,最后输出rank的时候按照initial playing order即可。

AC代码:

#include<iostream>
#include<stack>
#include<queue>
#include<cmath>
#include<algorithm>
#include<vector>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
queue<int>q,p;
int n,m,x;
int a[1005];
int r[1005];
int main(){
    cin>>n>>m;
    for(int i=0;i<n;i++){
        cin>>a[i];
    }
    for(int i=1;i<=n;i++){
        cin>>x;
        q.push(x);
    }
    while(1){
        int l=int(ceil(q.size()*1.0/m));//向上取整
        while(!q.empty()){            
            int mx=0;
            int k=-1;
            for(int i=1;i<=m;i++){//每m各一组
                if(!q.empty()){
                    x=q.front();
                    q.pop();
                    r[x]=l+1;//rank为组数+1
                    if(a[x]>mx){
                        mx=a[x];
                        k=x;
                    }
                }
            }
            p.push(k);//胜利者放入p
        }
        if(p.size()!=1){
            q=p;
            queue<int>empty;
            swap(p,empty);
        }else{
            r[p.front()]=1;
            break;
        }
    }
    for(int i=0;i<n;i++){
        cout<<r[i];
        if(i!=n-1) cout<<" ";
    }
    return 0;
}
原文地址:https://www.cnblogs.com/caiyishuai/p/13270635.html