PAT 甲级 1075 PAT Judge (25分)(较简单,注意细节)

1075 PAT Judge (25分)
 

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤), the total number of users, K (≤), the total number of problems, and M (≤), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then Mlines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either − if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

题意:

对于每个测试用例,您应该按照以下格式输出ranklist:

user_id total_score s[1]…s [K]

其中根据total_score计算rank,具有相同total_score的所有用户获得相同的rank;s[i]是第i个问题得到的部分分数。如果用户从未提交过问题的解决方案,则必须在相应位置打印“-”。如果用户为解决一个问题提交了多个解决方案,那么将计算最高分。

ranklist必须按秩的非递减顺序打印。对于具有相同级别的用户,必须根据完美解决的问题的数量按非递增顺序排序。如果仍然有领带,则必须按其id的递增顺序打印。对于那些从来没有提交过任何可以通过编译器的解决方案的人,或者从来没有提交过任何解决方案的人,他们不能显示在ranklist上。可以保证至少有一个用户可以显示在ranklist上。

题解:

注意点: 
1、最重要最重要的一点,一定一定要仔细看题,每一个细节,每一句话,都要认真理解。 
2、按照总分排序高低排序。 
3、总分相同,那么按照答对题目个数(完全正确,拿满分)进行排序。 
4、满足2、3条件,那么就需要按照学号进行排序。 
5、最后一个输出,一道题都没有提交或者提交但没有一道题通过编译的同学不输出。(一定要注意,提交没有通过编译和提交得零分完全是两个概念,所以在这里输出的时候一定要注意,后者是需要输出的) 
6、最后一个注意点是我自己的错,没有注意到第一个数N是user个数,那么下面提交的学生id是1-N。注意到了这一点,不至于把题想得很复杂。 
7、输出的时候,提交没有通过编译的题目输出0,没有提交的题目输出“-”。 
8、做这个题还有一个感受,一门语言,需要好好理解,深入理解,会帮助我们解题。

思路:上面的注意点都想到了的话,那么这道题并不难。First,在输入各个提交情况的时候,简单处理一下,then,计算每个user提交正确的题目数,next,调用一个sort函数进行进行排序,last 
,按照格式输出。over…
————————————————
版权声明:本文为CSDN博主「鬼鬼珊」的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/qq_41658889/article/details/82717767

AC代码:

#include<bits/stdc++.h>
using namespace std;
int n,m,k;
struct node{
    int id;
    int f=0;
    int fen[10]={-1,-1,-1,-1,-1,-1,-1,-1,-1,-1};
    int ok=0;
    int sum=0;
    int rank;
}a[10005];
int p[10];
bool cmp(node x,node y){
    if(x.sum==y.sum){
        if(x.ok==y.ok){
            return x.id<y.id;
        }else return x.ok>y.ok;
    }else return x.sum>y.sum;
    
}
int main(){
    cin>>n>>k>>m;
    for(int i=1;i<=k;i++) cin>>p[i];
    for(int i=1;i<=n;i++) a[i].id=i;
    for(int i=1;i<=m;i++){
        int x,y,z;
        cin>>x>>y>>z;
        if(z>=0) {//如果这个人已经得过分了,那么-1也要算作0
            a[x].f=1;
        }else{
            if(a[x].fen[y]==-1) a[x].fen[y]=0;//只要是提交了,原来是-1,要改为0 
            continue;
        } 
        if(z==p[y] && a[x].fen[y]<z) a[x].ok++;//第一次完全答对本题 
        if(a[x].fen[y]==-1){//计算总分 
            a[x].fen[y]=z;
            a[x].sum+=z;
        }else if(a[x].fen[y]<z){
            a[x].sum=a[x].sum-a[x].fen[y]+z;
            a[x].fen[y]=z;
        }
    }
    sort(a+1,a+1+n,cmp);
    a[1].rank=1;
    for(int i=1;i<=n;i++){
        if(a[i].f==0) continue;
        if(i!=1){//计算排名 
            if(a[i].sum==a[i-1].sum) a[i].rank=a[i-1].rank;
            else a[i].rank=i;
        }
        printf("%d %05d %d ",a[i].rank,a[i].id,a[i].sum);
        for(int j=1;j<=k;j++){
            if(a[i].fen[j]!=-1) cout<<a[i].fen[j];
            else cout<<"-";
            if(j!=k) cout<<" ";
            else cout<<endl; 
        }
    }
    return 0;
} 
原文地址:https://www.cnblogs.com/caiyishuai/p/11991057.html