PAT 甲级 1053 Path of Equal Weight (30 分)(dfs,vector内元素排序,有一小坑点)

1053 Path of Equal Weight (30 分)
 

Given a non-empty tree with root R, and with weight Wi​​ assigned to each tree node Ti​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0, the number of nodes in a tree, M (<), the number of non-leaf nodes, and 0, the given weight number. The next line contains N positive numbers where Wi​​ (<) corresponds to the tree node Ti​​. Then Mlines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence { is said to be greater than sequence { if there exists 1 such that Ai​​=Bi​​ for ,, and Ak+1​​>Bk+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题意:

给一个树,根为1 ,输出从根到叶子的权值和=m的所有路径(顺序有要求)

题解:

       乍一看,就是用vector存储各节点和它的子节点,然后再用个结构体队列bfs一下,后来发现路径是可以找到,但是bfs很难做到题目要求的输出顺序。

        所以,改用dfs,但dfs首先要对各节点的子节点按权重从大到小排序,就需要vector内元素排序,以前没用过,sort(v.begin(), v.end(), sortFun)。dfs以一个结构体为单位,存有遍历到的节点编号、权重和和路径p。

      但是测试点1一直过不了,有个小坑点,没注意到,就是根节点要特判,可能一个根节点就符合条件了,不需要再遍历了。

AC代码:

#include<iostream>
#include<stack>
#include<queue>
#include<cmath>
#include<algorithm>
#include<vector>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
int a[105];//每个点的权重
int n,m,w;
vector<int>v[105];//存储每个点的字节点编号
struct node{
    int key;//当前点编号
    int wei;//到当前点的权重和
    queue<int>p;//记录路径
};
bool sortFun(const int &p1, const int &p2)//vector内元素排序
{
    return a[p1] > a[p2];//升序排列  
}
void dfs(node x){
    for(int i=0;i<v[x.key].size();i++){
        node y;
        y.key=v[x.key].at(i);
        if(x.wei+a[y.key]==w&&v[y.key].size()==0){//必须要保证已经走到底了
            queue<int>Q=x.p;//输出
            while(!Q.empty()){
                cout<<Q.front()<<" ";
                Q.pop();
            }
            cout<<a[y.key]<<endl;
        }else if(x.wei+a[y.key]<w){//新的递归下去
            y.wei=x.wei+a[y.key];
            y.p=x.p;
            y.p.push(a[y.key]);
            dfs(y);
        }
    }
}

int main(){
    cin>>n>>m>>w;
    for(int i=0;i<n;i++) cin>>a[i];
    for(int i=1;i<=m;i++){
        int x,k;
        cin>>x>>k;
        for(int j=1;j<=k;j++){
            int y;
            cin>>y;
            v[x].push_back(y);
        }
        //因为输出的路径权重 要按降序,所以可以在DFS之前:给每一个结点的子节点排序
        sort(v[x].begin(), v[x].end(), sortFun);
    }
    if(a[0]==w){//坑点:根节点要特判
        cout<<a[0]<<endl;
    }else{
        node x;
        x.key=0;
        x.wei=a[0];
        while(!x.p.empty()) x.p.pop();
        x.p.push(a[0]);
        dfs(x);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/caiyishuai/p/11542220.html