Stars(树状数组)

算法学习:http://www.cnblogs.com/George1994/p/7710886.html

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1541

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
 
题目大意:求左下方有多少个点,包括左方和下方
个人思路:也没什么思路,就是用树状数组吧,第一次接触,有点难
看代码:
#include<iostream>
#include<string.h>
#include<map>
#include<cstdio>
#include<cstring>
#include<stdio.h>
#include<cmath>
#include<ctype.h>
#include<math.h>
#include<algorithm>
#include<set>
#include<queue>
typedef long long ll;
using namespace std;
const ll mod=1000;
const int maxn=15000+10;
const int maxk=32000+10;
const int maxx=1e4+10;
const ll maxe=1000+10;
#define INF 0x3f3f3f3f3f3f
#define Lson l,mid,rt<<1
#define Rson mid+1,r,rt<<1|1
int ans[maxn];//ans[i]代表有i个星星的点有多少个
int a[maxk];//a[i]代表横坐标为i的左下角(包括左和下)有多少个星星
int lowbit(int x)//可以求出x的二进制最低位1的位置的数值比如110,答案就是10
{
    return x&(-x);
}
int getsum(int x)//求有多少个点
{
    int sum=0;
    while(x>0)
    {
        sum+=a[x];
        x-=lowbit(x);
    }
    return sum;
}
void updata(int x)//更新操作
{
    while(x<maxk)
    {
        a[x]++;
        x+=lowbit(x);
    }
}
int main()
{
    int n,x,y;
    while(scanf("%d",&n)!=EOF)
    {
        memset(ans,0,sizeof(ans));
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)
        {
            cin>>x>>y;
            ans[getsum(x+1)]++;//因为x可能为0,但是树状数组是从1开始的,所以整个坐标往右移
            updata(x+1);
        }
        for(int i=0;i<n;i++)
            cout<<ans[i]<<endl;
    }
    return 0;
}
#include<iostream>
#include<cstdio>
#include<cstring>
#include<stdio.h>
#include<string.h>
#include<cmath>
#include<math.h>
#include<algorithm>
#include<set>
#include<queue>
typedef long long ll;
using namespace std;
const ll mod=1e9+7;
const int maxn=15050;
const ll maxa=32050;
#define INF 0x3f3f3f3f3f3f
int a[maxn],c[maxa];
int lowbit(int x)
{
    return x&(-x);
}
int getsum(int x)
{
    int res=0;
    while(x>0)
    {
        res+=c[x];
        x=x-lowbit(x);
    }
    return res;
}
void updata(int x)
{
    while(x<maxa)
    {
        c[x]++;
        x=x+lowbit(x);
    }
}
int main()
{
    int n,x,y;
    memset(a,0,sizeof(a));
    memset(c,0,sizeof(c));
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        cin>>x>>y;
        a[getsum(x+1)]++;
        updata(x+1);
    }
    for(int i=0;i<n;i++)
        cout<<a[i]<<endl;
    return 0;
}
当初的梦想实现了吗,事到如今只好放弃吗~
原文地址:https://www.cnblogs.com/caijiaming/p/9330795.html