Long Long Message

题目链接:http://poj.org/problem?id=2774

Long Long Message
Time Limit: 4000MS   Memory Limit: 131072K
Total Submissions: 36338   Accepted: 14572
Case Time Limit: 1000MS

Description

The little cat is majoring in physics in the capital of Byterland. A piece of sad news comes to him these days: his mother is getting ill. Being worried about spending so much on railway tickets (Byterland is such a big country, and he has to spend 16 shours on train to his hometown), he decided only to send SMS with his mother. 

The little cat lives in an unrich family, so he frequently comes to the mobile service center, to check how much money he has spent on SMS. Yesterday, the computer of service center was broken, and printed two very long messages. The brilliant little cat soon found out: 

1. All characters in messages are lowercase Latin letters, without punctuations and spaces. 
2. All SMS has been appended to each other – (i+1)-th SMS comes directly after the i-th one – that is why those two messages are quite long. 
3. His own SMS has been appended together, but possibly a great many redundancy characters appear leftwards and rightwards due to the broken computer. 
E.g: if his SMS is “motheriloveyou”, either long message printed by that machine, would possibly be one of “hahamotheriloveyou”, “motheriloveyoureally”, “motheriloveyouornot”, “bbbmotheriloveyouaaa”, etc. 
4. For these broken issues, the little cat has printed his original text twice (so there appears two very long messages). Even though the original text remains the same in two printed messages, the redundancy characters on both sides would be possibly different. 

You are given those two very long messages, and you have to output the length of the longest possible original text written by the little cat. 

Background: 
The SMS in Byterland mobile service are charging in dollars-per-byte. That is why the little cat is worrying about how long could the longest original text be. 

Why ask you to write a program? There are four resions: 
1. The little cat is so busy these days with physics lessons; 
2. The little cat wants to keep what he said to his mother seceret; 
3. POJ is such a great Online Judge; 
4. The little cat wants to earn some money from POJ, and try to persuade his mother to see the doctor :( 

Input

Two strings with lowercase letters on two of the input lines individually. Number of characters in each one will never exceed 100000.

Output

A single line with a single integer number – what is the maximum length of the original text written by the little cat.

Sample Input

yeshowmuchiloveyoumydearmotherreallyicannotbelieveit
yeaphowmuchiloveyoumydearmother

Sample Output

27

Source

POJ Monthly--2006.03.26,Zeyuan Zhu,"Dedicate to my great beloved mother."
 
题目大意:求两个串的最长公共子串
思路:后缀数组模板题,把两个字符串合并为一个字符串,求出这个字符串的sa数组和height数组   跑一遍height数组 判断是否属于两个数组就行了  看代码:
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
const int maxn=1e6+50;
char s1[maxn],s2[maxn],s[maxn];
int c[maxn];//桶子
int x[maxn];//x数组存储每个下标对应的权值
int sa[maxn],height[maxn],y[maxn],rk[maxn];
void get_SA(int len)
{
    int m=130;
    for(int i=1;i<=len;i++) ++c[x[i]=s[i]];//存每个字符有多少个

    for(int i=2;i<=130;i++) c[i]+=c[i-1];//每个字符最多排第几

    for(int i=len;i>=1;i--) sa[c[x[i]]--]=i;//按第一个字母字典序排序

    for(int k=1;k<=len;k<<=1)//倍增
    {
        int num=0;
        for(int i=len-k+1;i<=len;i++) y[++num]=i;
        for(int i=1;i<=len;i++) if(sa[i]>k) y[++num]=sa[i]-k;
        for(int i=1;i<=m;i++) c[i]=0;
        for(int i=1;i<=len;i++) ++c[x[i]];
        for(int i=2;i<=m;i++) c[i]+=c[i-1];
        for(int i=len;i>=1;i--) sa[c[x[y[i]]]--]=y[i],y[i]=0;
        swap(x,y);
        x[sa[1]]=1;
        num=1;
        for(int i=2;i<=len;i++) x[sa[i]]=(y[sa[i]]==y[sa[i-1]]&&y[sa[i]+k]==y[sa[i-1]+k])?num:++num;
        if(num==len) break;
        m=num;
    }
    //for(int i=1;i<=len;i++) cout<<sa[i]<<" "<<endl;
    return ;
}
void get_height(int len)
{
    for(int i=1;i<=len;i++)
    {
        rk[sa[i]]=i;
    }
    int k=0;
    for(int i=1;i<=len;i++)
    {
        if(rk[i]==1) continue;
        if(k) --k;
        int j=sa[rk[i]-1];
        while(j+k<=len&&i+k<=len&&s[i+k]==s[j+k]) ++k;
        height[rk[i]]=k;
    }
    return ;
}
int main()
{
    scanf("%s%s",s1,s2);
    int len1=strlen(s1);
    int len2=strlen(s2);

    int len=0;//从1开始存储
    for(int i=0;i<len1;i++)
    {
        s[++len]=s1[i];
    }


    //for(int i=1;i<=len;i++) cout<<s[i];cout<<endl;
    s[++len]='z'+1;

    for(int i=0;i<len2;i++) s[++len]=s2[i];

    //for(int i=1;i<=len;i++) cout<<s[i];cout<<endl;

    get_SA(len);
    get_height(len);
    int ans=0;
    for(int i=1;i<=len;i++)
    {
        if(height[i]>ans)
        {
            if(sa[i-1]>=0&&sa[i-1]<len1&&sa[i]>=len1) ans=height[i];
            if(sa[i-1]>=len1&&sa[i]>=0&&sa[i]<len1) ans=height[i];
        }
    }
    cout<<ans<<endl;
    return 0;
 }
当初的梦想实现了吗,事到如今只好放弃吗~
原文地址:https://www.cnblogs.com/caijiaming/p/10625567.html