openjudge ROADS

726:ROADS

总时间限制:
1000ms
内存限制:
65536kB
描述
N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.
输入
The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :
  • S is the source city, 1 <= S <= N
  • D is the destination city, 1 <= D <= N
  • L is the road length, 1 <= L <= 100
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.
输出
The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.
样例输入
5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2
样例输出
    11
题目大意:
n个点,m条边,每条边有长度和费用,需要求出1到n的在费用不大于k的情况下的最短路径,如果没有输出-1
这道题dijsktra算法即可,并且不能记录dis数组,直接在第一次到达n时即为ans;
如果记录dis可能会出现花费不足以到达终点但是总长度较短,导致输出-1。
#include<cstdio>
#include<queue>
using namespace std;
struct X
{
    int v,q,j,n,f;
    bool operator<(const X &a)const
    {
        if(q==a.q) return j>a.j;
        return q>a.q;
    }//重载运算符
}x[10005];
priority_queue<X>qq;//调用系统堆
int main()
{
    int k,n,m;
    scanf("%d%d%d",&k,&n,&m);
    for(int i=1;i<=m;i++)
    {
        int u;
        scanf("%d%d%d%d",&u,&x[i].v,&x[i].q,&x[i].j);
        x[i].n=x[u].f;
        x[u].f=i;
    }
    qq.push((X){1,0,0,0,0});//载入初始节点
    while(!qq.empty())
    {
        X t=qq.top();qq.pop();
        if(t.v==n)
        {
            printf("%d",t.q);//到达n即为最优解
            return 0;
        }
        for(int i=x[t.v].f;i;i=x[i].n)
            if(t.j+x[i].j<=k) qq.push((X){x[i].v,x[i].q+t.q,x[i].j+t.j,0,0});
    }
    printf("-1"); 
    return 0;
}
原文地址:https://www.cnblogs.com/bzmd/p/6217887.html