P2880 [USACO07JAN]平衡的阵容Balanced Lineup 线段树 树状数组

  

题目背景

题目描述:

每天,农夫 John 的N(1 <= N <= 50,000)头牛总是按同一序列排队. 有一天, John 决定让一些牛们玩一场飞盘比赛. 他准备找一群在对列中为置连续的牛来进行比赛. 但是为了避免水平悬殊,牛的身高不应该相差太大. John 准备了Q (1 <= Q <= 180,000) 个可能的牛的选择和所有牛的身高 (1 <= 身高 <= 1,000,000). 他想知道每一组里面最高和最低的牛的身高差别.

输入:

第1行:N,Q

第2到N+1行:每头牛的身高

第N+2到N+Q+1行:两个整数A和B,表示从A到B的所有牛。(1<=A<=B<=N)

输出:

输出每行一个数,为最大数与最小数的差

题目描述

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

一个农夫有N头牛,每头牛的高度不同,我们需要找出最高的牛和最低的牛的高度差。

输入输出格式

输入格式:

Line 1: Two space-separated integers, N and Q.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i

Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

输出格式:

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

输入输出样例

输入样例#1: 复制
6 3
1
7
3
4
2
5
1 5
4 6
2 2
输出样例#1: 复制
6
3
0


可以用线段树维护最大最小值
#include<bits/stdc++.h>
using namespace std;
//input by bxd
#define rep(i,a,b) for(int i=(a);i<=(b);i++)
#define repp(i,a,b) for(int i=(a);i>=(b);--i)
#define RI(n) scanf("%d",&(n))
#define RII(n,m) scanf("%d%d",&n,&m)
#define RIII(n,m,k) scanf("%d%d%d",&n,&m,&k)
#define RS(s) scanf("%s",s);
#define ll long long
#define pb push_back
#define REP(i,N)  for(int i=0;i<(N);i++)
#define CLR(A,v)  memset(A,v,sizeof A)
//////////////////////////////////
#define inf 0x3f3f3f3f
#define lson l,m,pos<<1
#define rson m+1,r,pos<<1|1
const int N=50000;
int MAX,MIN;
int maxx[N<<2],minn[N<<2];
void up(int pos)
{
    maxx[pos]=max(maxx[pos<<1],maxx[pos<<1|1]);
    minn[pos]=min(minn[pos<<1],minn[pos<<1|1]);
}
void build(int l,int r,int pos)
{
    if(l==r)
    {
        RI(maxx[pos]);
        minn[pos]=maxx[pos];
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    up(pos);
}
void query(int L,int R,int l,int r,int pos)
{
    if(L<=l&&r<=R)
    {
        MAX=max(MAX,maxx[pos]);
        MIN=min(MIN,minn[pos]);
        return ;
    }
    int m=(l+r)>>1;
    if(L<=m)query(L,R,lson);
    if(R>m)query(L,R,rson);
}

int main()
{
    int n,m;RII(n,m);
    build(1,n,1);
    while(m--)
    {
        MAX=0;MIN=inf;
        int a,b;RII(a,b);
        query(a,b,1,n,1);
        cout<<MAX-MIN<<endl;
    }
    return 0;
}
View Code
也可以用树状数组来维护最大最小值
注意写法:
#include<bits/stdc++.h>
using namespace std;
//input by bxd
#define rep(i,a,b) for(int i=(a);i<=(b);i++)
#define repp(i,a,b) for(int i=(a);i>=(b);--i)
#define RI(n) scanf("%d",&(n))
#define RII(n,m) scanf("%d%d",&n,&m)
#define RIII(n,m,k) scanf("%d%d%d",&n,&m,&k)
#define RS(s) scanf("%s",s);
#define ll long long
#define pb push_back
#define REP(i,N)  for(int i=0;i<(N);i++)
#define CLR(A,v)  memset(A,v,sizeof A)
//////////////////////////////////
#define inf 0x3f3f3f3f
#define lson l,m,pos<<1
#define rson m+1,r,pos<<1|1
const int N=50005;
int lowbit(int x){return x&-x;}
int n;
int ma[N],mi[N];
int c[N];
void add(int x,int v)
{
    for(int i=x;i<=n;i+=lowbit(i))
    ma[i]=max(ma[i],v),mi[i]=min(mi[i],v);
}
int sum(int L,int R)
{
    int maxx=-1,minn=inf;
    while(L<=R)
    {
        for(;R-lowbit(R)>=L;R-=lowbit(R) )maxx=max(maxx,ma[R]),minn=min(minn,mi[R]);
        maxx=max(c[R],maxx);minn=min(minn,c[R]);
        R--;
    }
    return maxx-minn;
}
int main()
{
    CLR(mi,0x3f);
    int m;RII(n,m);
    rep(i,1,n)
    {
        int x;RI(x);
        add(i,x);
        c[i]=x;
    }
    rep(i,1,m)
    {
        int a,b;RII(a,b);
        cout<<sum(a,b)<<endl;
    }
}
View Code


原文地址:https://www.cnblogs.com/bxd123/p/10832115.html