POJ 2823 Sliding Window & Luogu P1886 滑动窗口

Sliding Window

Time Limit: 12000MS   Memory Limit: 65536K
Total Submissions: 66613   Accepted: 18914
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

  

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

  

Source


题目描述

现在有一堆数字共N个数字(N<=10^6),以及一个大小为k的窗口。现在这个从左边开始向右滑动,每次滑动一个单位,求出每次滑动后窗口中的最大值和最小值。

例如:

The array is [1 3 -1 -3 5 3 6 7], and k = 3.

输入输出格式

输入格式:

 

输入一共有两行,第一行为n,k。

第二行为n个数(<INT_MAX).

 

输出格式:

 

输出共两行,第一行为每次窗口滑动的最小值

第二行为每次窗口滑动的最大值

 

输入输出样例

输入样例#1:
8 3
1 3 -1 -3 5 3 6 7

  

输出样例#1:
-1 -3 -3 -3 3 3
3 3 5 5 6 7

  

说明

50%的数据,n<=10^5

100%的数据,n<=10^6


 

有好多种玄学解法,但最快的是单调队列。

单调队列想学自己去找,这里直接上代码吧。

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<cmath>
#define MAXN 10000008
using namespace std;
int h,t;
int q[MAXN],p[MAXN],a[MAXN];
int n,k;
void findmin()
{
    h=1,t=0;
    for(int i=1;i<=n;++i)
    {
        while(h<=t&&q[t]>=a[i])
          t--;
        q[++t]=a[i];
        p[t]=i;
        while(p[h]<=i-k)
          h++;
        if(i>=k)
          cout<<q[h]<<' ';
    }
}
void findmax()
{
    h=1,t=0;
    for(int i=1;i<=n;++i)
    {
        while(h<=t&&q[t]<=a[i])
          t--;
        q[++t]=a[i];
        p[t]=i;
        while(p[h]<=i-k)
          h++;
        if(i>=k)
          printf("%d ",q[h]);
    }
}
int main()
{
    scanf("%d%d",&n,&k);
    for(int i=1;i<=n;i++)
      scanf("%d",&a[i]);
    findmin();
    memset(p,0,sizeof(p));
    memset(q,0,sizeof(q));
    cout<<endl;
    findmax();
}

 

作者:wlz
本文版权归作者和博客园共有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利。
原文地址:https://www.cnblogs.com/bljfy/p/8727799.html