POJ 1904 King's Quest(强连通)

Language:
King's Quest
Time Limit: 15000MS   Memory Limit: 65536K
Total Submissions: 7635   Accepted: 2769
Case Time Limit: 2000MS

Description

Once upon a time there lived a king and he had N sons. And there were N beautiful girls in the kingdom and the king knew about each of his sons which of those girls he did like. The sons of the king were young and light-headed, so it was possible for one son to like several girls. 

So the king asked his wizard to find for each of his sons the girl he liked, so that he could marry her. And the king's wizard did it -- for each son the girl that he could marry was chosen, so that he liked this girl and, of course, each beautiful girl had to marry only one of the king's sons. 

However, the king looked at the list and said: "I like the list you have made, but I am not completely satisfied. For each son I would like to know all the girls that he can marry. Of course, after he marries any of those girls, for each other son you must still be able to choose the girl he likes to marry." 

The problem the king wanted the wizard to solve had become too hard for him. You must save wizard's head by solving this problem. 

Input

The first line of the input contains N -- the number of king's sons (1 <= N <= 2000). Next N lines for each of king's sons contain the list of the girls he likes: first Ki -- the number of those girls, and then Ki different integer numbers, ranging from 1 to N denoting the girls. The sum of all Ki does not exceed 200000. 

The last line of the case contains the original list the wizard had made -- N different integer numbers: for each son the number of the girl he would marry in compliance with this list. It is guaranteed that the list is correct, that is, each son likes the girl he must marry according to this list. 

Output

Output N lines.For each king's son first print Li -- the number of different girls he likes and can marry so that after his marriage it is possible to marry each of the other king's sons. After that print Li different integer numbers denoting those girls, in ascending order.

Sample Input

4
2 1 2
2 1 2
2 2 3
2 3 4
1 2 3 4

Sample Output

2 1 2
2 1 2
1 3
1 4

Hint

This problem has huge input and output data,use scanf() and printf() instead of cin and cout to read data to avoid time limit exceed.

Source



借鉴链接:http://blog.csdn.net/l04205613/article/details/6654820


题意是,N个男生和N个女生,告诉你每一个男生喜欢的女生编号,然后给出一个初始匹配(这个初始匹配是完备匹配),然后求全部可能的完备匹配,按升序输出。当然。假设暴整的话(当然我没试过)。2000个男生+2000个女生,最多有20W条有向边

看了一个神牛的报告,把这个转化成强连通问题:

首先依照给出的有向边建图,然后依据最后的那个完备匹配在图中增加反向边(就是依据那个完备匹配连 女生 到 男生 的边),那么在这个图中,属于同一个强连通的点对一定是合法点对。把他们排序输出就可以。


由于男生是不会爱男生的。所以假设是强连通,那么男生肯定是爱这个强连通分量中的全部女生的


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

#define fre(i,a,b)  for(i = a; i <b; i++)
#define free(i,b,a) for(i = b; i >= a;i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define ssf(n)      scanf("%s", n)
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi
")

using namespace std;

#define INF 0x3f3f3f3f
#define N 20000

int ans[N],time_num,time[N],low[N],type[N],cnt;
int instack[N];
int n;

vector<int>g[N];
stack<int>q;

void tarjan(int x)
{
	int i,j;
	time[x]=low[x]=++time_num;
	instack[x]=1;
	q.push(x);
	fre(i,0,g[x].size())
	{
		int to=g[x][i];
		if(time[to]==0)
		{
			tarjan(to);
			if(low[to]<low[x]) low[x]=low[to];
		}
       else
		 if(instack[to]&&low[x]>low[to])
		   low[x]=low[to];
	}
    int to;
    if(time[x]==low[x])
	{
		 cnt++;

		 do{
			to=q.top();
			 q.pop();
			 type[to]=cnt;
		     instack[to]=0;

		 }while(to!=x);
	}
}

void solve()
{
    int i,j;
	mem(time,0);
	mem(low,0);
	mem(instack,0);
	time_num=0;

	int k;
	while(!q.empty()) q.pop();

	mem(type,0);
	cnt=0;

	fre(i,1,n*2+1)
	 if(time[i]==0)
		tarjan(i);

	fre(i,1,n+1)
	{
		k=0;
		fre(j,0,g[i].size())
			if(type[i]==type[g[i][j]])
			 ans[k++]=g[i][j]-n;

	    sort(ans,ans+k);

	    pf("%d",k);
	    fre(j,0,k)
	      pf(" %d",ans[j]);
	    pf("
");
	}


}
int main()
{
	int i,j;
	while(~sf(n))
	{
		fre(i,1,n+n+1)
		 g[i].clear();

		 int k,x;
		fre(i,1,n+1)
		{

			sf(k);
			while(k--)
			{
				sf(x);
				g[i].push_back(n+x);   //男生爱女生
			}
		}

       fre(i,1,n+1)
        {
        	sf(x);
        	g[x+n].push_back(i);     //女生爱男生,假设这一种爱的关系是一种强连通。那么男生都能够选里面的女生
        }
       solve();
	}
    return 0;
}


原文地址:https://www.cnblogs.com/blfbuaa/p/7397494.html