3-7 类的友元函数的应用

题目描写叙述

通过本题目的练习能够掌握类的友元函数的定义和使用方法
要求设计一个点类Point,它具有两个double型的数据成员x。y。

为该类设计构造函数。并为其加入一个友元函数用于计算并输出两点间的距离;再加入一个输出成员函数用于输出点的信息。

并编写主函数。实现下面的输入输出内容。

输入

4double型的数,中间用一个空格间隔。

输出

输出数据共3行。前两行用于显示要求距离的两个点的信息,第三行显示两点的距离。

演示样例输入

5 6 2 3

演示样例输出

The first point is the coordinate:X=5,Y=6
The second point is the coordinate:X=2,Y=3
The distance between the two points is:4.24264
#include <iostream>
#include <cmath >
using namespace std;
class point
{
private:
    double x;
    double y;
    double x1;
    double y1;
public:
    friend void distance(point &);
    void setpoint()
    {
        cin>>x>>y>>x1>>y1;
    }
    void showpoint()
    {
        cout<<"The first point is the coordinate:X="<<x<<",Y="<<y<<endl;
        cout<<"The second point is the coordinate:X="<<x1<<",Y="<<y1<<endl;
    }
};
void distance(point &a)
{
    double k,j;
    j=(a.x-a.x1)*(a.x-a.x1)+(a.y-a.y1)*(a.y-a.y1);
    k=sqrt(j);
    cout<<"The distance between the two points is:"<<k<<endl;
}
int main()
{
    point d;
    d.setpoint();
    d.showpoint();
    distance(d);
    return 0;
}

原文地址:https://www.cnblogs.com/bhlsheji/p/5351708.html