POJ1595_Prime Cuts【素数】【水题】

Prime Cuts
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 10464Accepted: 3994

Description

A prime number is a counting number (1, 2, 3, ...) that is evenly divisible only by 1 and itself. In this problem you are to write a program that will cut some number of prime numbers from the list of prime numbers between (and including) 1 and N. Your program will read in a number N; determine the list of prime numbers between 1 and N; and print the C*2 prime numbers from the center of the list if there are an even number of prime numbers or (C*2)-1 prime numbers from the center of the list if there are an odd number of prime numbers in the list.


Input
Each input set will be on a line by itself and will consist of 2 numbers. The first number (1 <= N <= 1000) is the maximum number in the complete list of prime numbers between 1 and N. The second number (1 <= C <= N) defines the C*2 prime numbers to be printed from the center of the list if the length of the list is even; or the (C*2)-1 numbers to be printed from the center of the list if the length of the list is odd.


Output

For each input set, you should print the number N beginning in column 1 followed by a space, then by the number C, then by a colon (:), and then by the center numbers from the list of prime numbers as defined above. If the size of the center list exceeds the limits of the list of prime numbers between 1 and N, the list of prime numbers between 1 and N (inclusive) should be printed. Each number from the center of the list should be preceded by exactly one blank. Each line of output should be followed by a blank line. Hence, your output should follow the exact format shown in the sample output.


Sample Input

21 2
18 2
18 18

100 7


Sample Output

21 2: 5 7 11

18 2: 3 5 7 11

18 18: 1 2 3 5 7 11 13 17

100 7: 13 17 19 23 29 31 37 41 43 47 53 59 61 67



题目大意:给你两个数N和C,算出1~N(包含N)之间的素数序列,

若素数个数为奇数,则输出素数序列中心的2*C-1个素数。

若素数个数为偶数。则输出素数序列中心的2*C个素数。

输出个数中说若C>素数个数。则输出整个素数序列。

思路:筛法求素数打表,之后求出素数序列的中心位置。推断奇偶并输出

注意:此题中。1被当做了质数(仅仅限本题),数据规模开成1000是不够

的。须要开成1100。应该是測试数据超范围了。


#include<stdio.h>

int Prime[1100],PrimeNum[1100];

int IsPrime()
{
    for(int i = 1; i <= 1100; i++)
        Prime[i] = 1;
    for(int i = 2; i <= 1100; i++)
    {
        for(int j = i+i; j <= 1100; j+=i)
            Prime[j] = 0;
    }
    int num = 1;
    for(int i = 0; i <= 1100; i++)
        if(Prime[i])
            PrimeNum[num++] = i;
    return num;
}
int main()
{
    int num = IsPrime();
    int N,C,pos;
    while(~scanf("%d%d",&N,&C))
    {
        pos = 0;
        for(int i = 1; i < num; i++)
        {
            if(N >= PrimeNum[i] && N < PrimeNum[i+1])
            {
                pos = i;
                break;
            }
        }
        printf("%d %d:",N,C);
        if(C > pos && pos%2==0)
            C = pos/2;
        else if(C > pos)
            C = (pos+1)/2;
        if(pos%2 == 1)
        {
            for(int i = (pos-(C*2-1))/2+1; i <= (pos-(C*2-1))/2+C*2-1; i++)
                printf(" %d",PrimeNum[i]);
            printf("

");
        }
        else
        {
            for(int i = (pos-C*2)/2+1; i <= (pos-C*2)/2+C*2; i++)
                printf(" %d",PrimeNum[i]);
            printf("

");
        }


    }
        return 0;
}


原文地址:https://www.cnblogs.com/bhlsheji/p/5332340.html