HDOJ 1316 How Many Fibs?


JAVA大数....


How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3906    Accepted Submission(s): 1545


Problem Description
Recall the definition of the Fibonacci numbers: 
f1 := 1 
f2 := 2 
fn := fn-1 + fn-2 (n >= 3) 

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b]. 
 

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
 

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b. 
 

Sample Input
10 100 1234567890 9876543210 0 0
 

Sample Output
5 4
 

Source
 


import java.util.*;
import java.math.*;
import java.io.*;

public class Main
{
	public static void main(String[] args)
	{
		Scanner cin=new Scanner(System.in);
		
		final BigInteger maxlimit=BigInteger.TEN.pow(100);
		BigInteger[] fib=new BigInteger[500];
		
		fib[0]=BigInteger.ONE;
		fib[1]=BigInteger.valueOf(2);
		
		for(int i=2;i<500;i++)
		{
			fib[i]=fib[i-1].add(fib[i-2]);
		}
		
		while(cin.hasNextBigInteger())
		{
			BigInteger a=cin.nextBigInteger();
			BigInteger b=cin.nextBigInteger();
			if(a.compareTo(BigInteger.ZERO)==0&&b.compareTo(BigInteger.ZERO)==0)
				break;
			int ans=0;
			for(int i=0;i<500;i++)
			{
				if(fib[i].compareTo(a)>=0&&fib[i].compareTo(b)<=0)
					ans++;
			}
			System.out.println(ans);
		}
	}	
}



原文地址:https://www.cnblogs.com/bhlsheji/p/5322992.html