POJ 1160 Post Office (动态规划)

Post Office
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 15412   Accepted: 8351

Description

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates. 

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum. 

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. 

Input

Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output

The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

Sample Output

9

Source


题目大意:

有n个村庄,m个邮局。每一个村庄的位置坐标告诉你,如今要将m个邮局设立在这n个村庄里面,问你最小花费是多少?花费为每一个村庄到近期的邮局的距离和。


解题思路:

dp[i][j] 记录 i个邮局 j个村庄的最小花费,cost[k+1][j]。记录在k+1号村庄到 j 号村庄设立一个邮局的最小花费。

那么:dp[i][j]=min { dp[i][k]+cost[k+1][j] }

最后输出dp[m][n]就可以。

可是在k+1号村庄到 j 号村庄设立一个邮局的最小花费是多少呢?答案:中位数。设置在中间那个村庄就可以。


解题代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn=310;
const int maxm=40;
int cost[maxn][maxn],dp[maxm][maxn],a[maxn];
int n,m,s[maxn][maxn];

void input(){
    for(int i=1;i<=n;i++) scanf("%d",&a[i]);
    memset(dp,-1,sizeof(dp));
    for(int i=1;i<=n;i++){
        for(int j=i+1;j<=n;j++){
            cost[i][j]=0;
            int mid=(i+j)/2;
            for(int k=i;k<=j;k++){
                cost[i][j]+=abs(a[k]-a[mid]);
            }
        }
    }
}

int DP(int c,int r){
    if(dp[c][r]!=-1) return dp[c][r];
    if(c==1) return cost[1][r];
    int ans=(1<<30);
    for(int i=1;i<r;i++){
        int tmp=DP(c-1,i)+cost[i+1][r];
        if(tmp<ans) ans=tmp;
    }
    return dp[c][r]=ans;
}

void solve(){
    cout<<DP(m,n)<<endl;
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        input();
        solve();
    }
    return 0;
}



原文地址:https://www.cnblogs.com/bhlsheji/p/5177213.html