[ACM] poj 1088 滑雪 (内存搜索DFS)

滑雪
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 73409   Accepted: 27141

Description

Michael喜欢滑雪百这并不奇怪, 由于滑雪的确非常刺激。

但是为了获得速度,滑的区域必须向下倾斜,并且当你滑到坡底。你不得不再次走上坡或者等待升降机来载你。

Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每一个数字代表点的高度。以下是一个样例 

 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人能够从某个点滑向上下左右相邻四个点之中的一个,当且仅当高度减小。在上面的样例中。一条可滑行的滑坡为24-17-16-1。

当然25-24-23-...-3-2-1更长。其实。这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。以下是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

Source


解题思路:

记忆化搜索比普通的搜索效率要高。已经搜索过的就不用再搜索了,有DP的思想.step[i][j] 保存的是当前坐标i,j能够到达的最大距离(不包含自己),比方3 2 1,当前是3,那么能够到达的最大距离为2,对于每一个坐标,能够上下左右四个方向搜索,取距离最大的那个,作为该坐标的step[][]。

记忆化搜索这里体现的就是当搜索到某一个坐标时,该坐标的step[][]已经有值(搜索过了),且肯定是最优的,那么直接返回该step[][]值就能够了。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=110;
int mp[maxn][maxn];
int step[maxn][maxn];
int dx[4]={0,0,-1,1};
int dy[4]={1,-1,0,0};
int n,m;

bool judge(int x,int y)
{
    if(x>=1&&x<=n&&y>=1&&y<=m)
        return true;
    return false;
}

int dfs(int x,int y)//当前位置所能到达的最大距离
{
    if(step[x][y])//搜索过的就不用再又一次搜索,直接返回其值
        return step[x][y];
    for(int i=0;i<4;i++)
    {
        int nextx=x+dx[i];
        int nexty=y+dy[i];
        if(judge(nextx,nexty)&&mp[nextx][nexty]<mp[x][y])
        {
            int temp=dfs(nextx,nexty)+1;
            if(temp>step[x][y])//四个方向取最大值
                step[x][y]=temp;
        }
    }
    return step[x][y];
}

int main()
{
    scanf("%d%d",&n,&m);
    memset(step,0,sizeof(step));
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        scanf("%d",&mp[i][j]);
    int ans=0;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        {
            step[i][j]=dfs(i,j);
            if(ans<step[i][j])
                ans=step[i][j];
        }
    printf("%d",ans+1);//注意+1,由于本身也是序列里的一员(第一个)
    return 0;
}


版权声明:本文博客原创文章。博客,未经同意,不得转载。

原文地址:https://www.cnblogs.com/bhlsheji/p/4663664.html