1041.simple sorting

题目描述:

You are given an unsorted array of integer numbers. Your task is to sort this array and kill possible duplicated elements occurring in it.
输入:

For each case, the first line of the input contains an integer number N representing the quantity of numbers in this array(1≤N≤1000). Next N lines contain N integer numbers(one number per each line) of the original array.
输出:

For each case ,outtput file should contain at most N numbers sorted in ascending order. Every number in the output file should occur only once.
样例输入:
6
8 8 7 3 7 7
样例输出:
3 7 8

#include<iostream>
#include<algorithm>
using namespace std;

int a[1001],b[1001];
int n;

int main(){
    int i;
    while(cin>>n){
        for(i=0;i<n;i++)
        {
            cin>>a[i];
        }
        sort(a,a+n);
        int num=0;
        b[0]=a[0];
        for(i=1;i<n;i++)
        {
            if(a[i]!=a[i-1]) b[++num]=a[i];
        }
        bool first=true;
        for(i=0;i<=num;i++){
            if(first) {
                first=false;
                cout<<b[i];
            }
            else cout<<" "<<b[i];
        }
        cout<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/bernieloveslife/p/9736523.html