1039.zero-complexity transposition

题目描述:

You are given a sequence of integer numbers. Zero-complexity transposition of the sequence is the reverse of this sequence. Your task is to write a program that prints zero-complexity transposition of the given sequence.

输入:

For each case, the first line of the input file contains one integer n-length of the sequence (0 < n ≤ 10 000). The second line contains n integers numbers-a1, a2, …, an (-1 000 000 000 000 000 ≤ ai ≤ 1 000 000 000 000 000).

输出:

For each case, on the first line of the output file print the sequence in the reverse order.

样例输入:
5
-3 4 6 -8 9
样例输出:
9 -8 6 4 -3
#include<iostream>
using namespace std;

int main(){
    int n,i;
    long long a[10001];
    while(cin>>n){
    bool first=true;
    for(i=0;i<n;i++)
    {
        cin>>a[i];
    }
    for(i=n-1;i>=0;i--){
        if(first){
            first=false;
            cout<<a[i];
        }
        else cout<<" "<<a[i];
    }
    cout<<endl;
}
     return 0;
}
原文地址:https://www.cnblogs.com/bernieloveslife/p/9736517.html