1043.day of week

题目描述:

We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

输入:

There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.

输出:

Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.

样例输入:
9 October 2001
14 October 2001
样例输出:
Tuesday
Sunday
提示:

Month and Week name in Input/Output:
January, February, March, April, May, June, July, August, September, October, November, December
Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday

#include<stdio.h>
#include<string.h>
#define ISYEAP(x) x%100!=0 && x%4==0 ||x%400==0?1:0

int dayofmonth[13][2]=
{
    0,0,
    31,31,
    28,29,
    31,31,
    30,30,
    31,31,
    30,30,
    31,31,
    31,31,
    30,30,
    31,31,
    30,30,
    31,31,
};


struct date{
    int day;
    int month;
    int year;
    void nextday()
    {
        day++;
        if(day>dayofmonth[month][ISYEAP(year)]){
            day=1;
            month++;
            if(month>12)
            {
                month=1;
                year++;
            }
        }
    }
};

int buf[3001][13][32];
char monthname[13][20]=
{
    "",
    "January",
    "Feburary",
    "March",
    "April",
    "May",
    "June",
    "July",
    "August",
    "September",
    "October",
    "November",
    "December"
};

char weekname[7][20]=
{
    "Sunday",
    "Monday",
    "Tuesday",
    "Wednesday",
    "Thursday",
    "Friday",
    "Saturday"
};

int main(){
    date temp;
    int cnt=0;
    temp.day=1;
    temp.month=1;
    temp.year=0;
    while(temp.year!=3001){
        buf[temp.year][temp.month][temp.day]=cnt;
        temp.nextday();
        cnt++;
    }
    int d,m,y;
    char s[20];
    while(scanf("%d%s%d",&d,s,&y)!=EOF)
    {
        for(m=1;m<13;m++)
        {
            if(strcmp(s,monthname[m]==0))
            {
                break;
            }
        }
        int days=buf[y][m][d]-buf[2012][7][16];
        days+=1;
        puts(weekname[(days%7+7)%7]);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/bernieloveslife/p/9736456.html