1109.连通图**

题目描述:
给定一个无向图和其中的所有边,判断这个图是否所有顶点都是连通的。
输入:
每组数据的第一行是两个整数 n 和 m(0<=n<=1000)。n 表示图的顶点数目,m 表示图中边的数目。如果 n 为 0 表示输入结束。随后有 m 行数据,每行有两个值 x 和 y(x<=n)(y <=n),表示顶点 x 和 y 相连,顶点的编号从 1 开始计算。输入不保证这些边是否重复。
输出:
对于每组输入数据,如果所有顶点都是连通的,输出”YES”,否则输出”NO”。
样例输入:
4 3
1 2
2 3
3 2
3 2
1 2
2 3
0 0
样例输出:
NO
YES

#include<iostream>
using namespace std;

int tree[1001];
int findroot(int x){
    if(tree[x]==-1) return x;
    else {
        int temp=findroot(tree[x]);
        tree[x]=temp;
        return temp;
    }
}

int main(){
    int n,m;
    while(cin>>n>>m && n!=0){
        for(int i=1;i<=n;i++) tree[i]=-1;
        while(m--!=0){
            int a,b;
            cin>>a>>b;
            a=findroot(a);
            b=findroot(b);
            if(a!=b) tree[a]=b;
        }
        int ans=0;
        for(int i=1;i<=n;i++){
            if(tree[i]==-1) ans++;
        }
        if(ans>1) cout<<"NO"<<endl;
        else cout<<"YES"<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/bernieloveslife/p/9736409.html