1143.Primary Arithmetic

题目描述:

    Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty. 

输入:

    Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.

输出:

    For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.

样例输入:
123 456
555 555
123 594
0 0
样例输出:
NO carry operation.
3 carry operations.
1 carry operation.
来源:
2009年北京大学计算机研究生机试真题
#include<iostream>
#include<cstring>
using namespace std;

int main(){
    string n,m;
    int i,j;
    while(cin>>n>>m && n!="0"){
        int num=0;
        int sum[200]={0};
        for(i=n.size()-1,j=199;i>=0;i--,j--){
            sum[j]+=n[i]-'0';
        }
        for(i=m.size()-1,j=199;i>=0;i--,j--){
            sum[j]+=m[i]-'0';
        }
        for(j=199;j>=0;j--){
            if(sum[j]>9){
                  sum[j]-=10;
                  num++;
                  sum[j-1]++;
            }
        }
        if(num==0) cout<<"NO carry operation."<<endl;
        else if(num==1){
                 cout<<"1 carry operation."<<endl;
        }
        else cout<<num<<" carry operations."<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/bernieloveslife/p/9735104.html