poj A Simple Problem with Integers

A Simple Problem with Integers
Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 37225   Accepted: 10745
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000. The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000. Each of the next Q lines represents an operation. "C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000. "Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

 
分析:线段树:成段增加,成段求和。
#include<cstdio>
#include<cstring>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long u64;
u64 sum[1 << 18];
int col[1 << 18];

void pushup(int rt) {
    sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}

void pushdown(int rt, int len) {
    if (col[rt]) {
        col[rt << 1] += col[rt];
        col[rt << 1 | 1] += col[rt];
        sum[rt << 1] += (u64) (len - (len >> 1)) * col[rt];
        sum[rt << 1 | 1] += (u64) (len >> 1) * col[rt];
        col[rt] = 0;
    }
}

void build(int l, int r, int rt) {
    if (l == r) {
        scanf("%lld", &sum[rt]);
        return;
    }
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
    pushup(rt);
}

void update(int L, int R, int c, int l, int r, int rt) {
    if (L <= l && R >= r) {
        col[rt] += c;
        sum[rt] += (u64) c * (r - l + 1);
        return;
    }
    pushdown(rt, r - l + 1);
    int m = (l + r) >> 1;
    if (L <= m)
        update(L, R, c, lson);
    if (R > m)
        update(L, R, c, rson);
    pushup(rt);
}

u64 query(int L, int R, int l, int r, int rt) {
    if (L <= l && R >= r) {
        return sum[rt];
    }
    pushdown(rt, r - l + 1);
    int m = (l + r) >> 1;
    u64 ans = 0;
    if (L <= m)
        ans += query(L, R, lson);
    if (R > m)
        ans += query(L, R, rson);
    return ans;
}

int main() {
    int n, m, a, b, c;
    char op[4];
    while (scanf("%d%d", &n, &m) != EOF) {
        memset(col, 0, sizeof (col));
        build(1, n, 1);
        while (m--) {
            scanf("%s", op);
            if (op[0] == 'Q') {
                scanf("%d%d", &a, &b);
                printf("%lld\n", query(a, b, 1, n, 1));
            } else if (op[0] == 'C') {
                scanf("%d%d%d", &a, &b, &c);
                update(a, b, c, 1, n, 1);
            }
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/baidongtan/p/2717023.html