hdu Trucking

Trucking

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 55    Accepted Submission(s): 19
 
Problem Description
A certain local trucking company would like to transport some goods on a cargo truck from one place to another. It is desirable to transport as much goods as possible each trip. Unfortunately, one cannot always use the roads in the shortest route: some roads may have obstacles (e.g. bridge overpass, tunnels) which limit heights of the goods transported. Therefore, the company would like to transport as much as possible each trip, and then choose the shortest route that can be used to transport that amount.
For the given cargo truck, maximizing the height of the goods transported is equivalent to maximizing the amount of goods transported. For safety reasons, there is a certain height limit for the cargo truck which cannot be exceeded.
 
Input
The input consists of a number of cases. Each case starts with two integers, separated by a space, on a line. These two integers are the number of cities (C) and the number of roads (R). There are at most 1000 cities, numbered from 1. This is followed by R lines each containing the city numbers of the cities connected by that road, the maximum height allowed on that road, and the length of that road. The maximum height for each road is a positive integer, except that a height of -1 indicates that there is no height limit on that road. The length of each road is a positive integer at most 1000. Every road can be travelled in both directions, and there is at most one road connecting each distinct pair of cities. Finally, the last line of each case consists of the start and end city numbers, as well as the height limit (a positive integer) of the cargo truck. The input terminates when C = R = 0.
 
Output
For each case, print the case number followed by the maximum height of the cargo truck allowed and the length of the shortest route. Use the format as shown in the sample output. If it is not possible to reach the end city from the start city, print "cannot reach destination" after the case number. Print a blank line between the output of the cases.
 
Sample Input
5 6
1 2 7 5
1 3 4 2
2 4 -1 10
2 5 2 4
3 4 10 1
4 5 8 5
1 5 10
5 6
1 2 7 5
1 3 4 2
2 4 -1 10
2 5 2 4
3 4 10 1
4 5 8 5
1 5 4
3 1
1 2 -1 100
1 3 10
0 0
 
Sample Output
Case 1:
maximum height = 7
length of shortest route = 20

Case 2:
maximum height = 4
length of shortest route = 8

Case 3:
cannot reach destination
 
 
Source
2008 Rocky Mountain Regional
 
Recommend
gaojie
 

分析:先用并查集判连通来确定高度限制,然后直接用迪杰特斯拉+优先队列计算最短路。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
#define maxn 0x7fffffff
typedef pair<int, int> pii;

typedef struct S1 {
    int u, v, height, len;
} EDGE;
EDGE edge[500010];
int k;

bool cmp(EDGE a, EDGE b) {
    return a.height > b.height;
}

typedef struct S2 {
    int v, w;
    struct S2 *next;
} LINK;
LINK *node[1010], temp[1000010];
int cnt;
int vis[1010], d[1010];

void add(int a, int b, int c) {
    temp[cnt].v = b;
    temp[cnt].w = c;
    temp[cnt].next = node[a];
    node[a] = &temp[cnt++];
}
int fa[1010];

int find(int x) {
    if (x != fa[x])
        fa[x] = find(fa[x]);
    return fa[x];
}

void merge(int a, int b) {
    a = find(a);
    b = find(b);
    if (a != b)
        fa[a] = b;
}

int main() {
    int n, m, i, j, a, b, h, l, limit, start, end, f1, f2, first = 0, T = 0;
    pii U;
    while (scanf("%d%d", &n, &m) != EOF && n) {
        if (!first)
            first = 1;
        else
            printf("\n");
        printf("Case %d:\n", ++T);
        for (i = 1; i <= n; ++i) {
            fa[i] = i;
            node[i] = NULL;
            d[i] = maxn;
        }
        cnt = k = 0;
        while (m--) {
            scanf("%d%d%d%d", &a, &b, &h, &l);
            if (h == -1) {
                add(a, b, l);
                add(b, a, l);
                merge(a, b);
            } else {
                edge[k].u = a;
                edge[k].v = b;
                edge[k].height = h;
                edge[k].len = l;
                ++k;
            }
        }
        sort(edge, edge + k, cmp);
        scanf("%d%d%d", &start, &end, &limit);
        for (i = 0;;) {
            while (edge[i].height >= limit) {
                add(edge[i].u, edge[i].v, edge[i].len);
                add(edge[i].v, edge[i].u, edge[i].len);
                merge(edge[i].u, edge[i].v);
                ++i;
                if (i >= k)
                    break;
            }
            f1 = find(start);
            f2 = find(end);
            if (f1 == f2 || i >= k)
                break;
            else
                limit = edge[i].height;
        }
        if (i >= k && f1 != f2) {
            printf("cannot reach destination\n");
            continue;
        }
        d[start] = 0;
        priority_queue<pii, vector<pii>, greater<pii> >q;
        q.push(make_pair(0, start));
        memset(vis, 0, sizeof (vis));
        while (!q.empty()) {
            U = q.top();
            q.pop();
            a = U.second;
            if (a == end)
                break;
            vis[a] = 1;
            LINK *t;
            t = node[a];
            for (; t; t = t->next) {
                b = t->v;
                if (!vis[b] && d[a] + t->w < d[b]) {
                    d[b] = d[a] + t->w;
                    q.push(make_pair(d[b], b));
                }
            }
        }
        printf("maximum height = %d\nlength of shortest route = %d\n", limit, d[end]);
    }
    return 0;
}
这条路我们走的太匆忙~拥抱着并不真实的欲望~
原文地址:https://www.cnblogs.com/baidongtan/p/2710052.html