hdu Dragon Balls

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 232    Accepted Submission(s): 126
 
Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it\\\\\\\'s too difficult for Monkey King(WuKong) to gather all of the dragon balls together.His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities\\\\\\\' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 
Input
The first line of the input is a single positive integer T(0 < T <= 100). For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000). Each of the following Q lines contains either a fact or a question as the follow format:   T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.   Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 
Output
            For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 
Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1
 
Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2
 
Author
possessor WC
 
Source
2010 ACM-ICPC Multi-University Training Contest(19)——Host by HDU
 
Recommend
lcy

分析:并查集+路径压缩。难点在于移动次数使用路径压缩。

#include<cstdio>
#include<cstring>
using namespace std;
#define MAXN 10010
int fa[MAXN],move[MAXN],num[MAXN];
int find(int x)
{
    if(x==fa[x])
        return x;
    int t=fa[x];
    fa[x]=find(fa[x]);
    move[x]+=move[t];
    return fa[x];
}
void merge(int x,int y)
{
    int fx,fy;
    fx=find(x);
    fy=find(y);
    if(fx==fy)
        return;
    fa[fx]=fy;
    num[fy]+=num[fx];
    move[fx]=1;
}
char op[5];
int main()
{
    int T,t,n,m,i,a,b;
    scanf("%d",&T);
    for(t=1;t<=T;++t)
    {
        printf("Case %d:\n",t);
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;++i)
        {
            fa[i]=i;
            num[i]=1;
        }
        memset(move,0,sizeof(move));
        while(m--)
        {
            scanf("%s%d",op,&a);
            if(op[0]=='T')
            {
                scanf("%d",&b);
                merge(a,b);
            }
            else if(op[0]=='Q')
            {
                b=find(a);
                printf("%d %d %d\n",b,num[b],move[a]);
            }
        }       
    }
    return 0;
}
原文地址:https://www.cnblogs.com/baidongtan/p/2672404.html