自测-5 Shuffling Machine

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the ii-th position is jj, it means to move the card from position ii to position jj. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer KK (le 2020) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

  此题考虑有原始次序,和变化次序。即变化次序始终都是不变的,每一次改变顺序,都是用变化次序去将原始次序改变得到新的原始次序。

注意变通能力。

#include <stdio.h>
#include<string.h>
int main()
{
    char ch, ch1[2], temp[2]; 
    int order_init[54], order_final[54], a[54];
    int times = 0, i = 0, j = 0;
    scanf("%d", &times);
    // 给”顺序“赋值a,以及给初始排序赋值order_init
    for(; i < 54; i++){
        scanf("%d", &a[i]);
        a[i]--;
        order_init[i] = i;
    }
    // 通过循环,改变次序,得到最终的顺序
    while(times--){
        
        for(i = 0; i < 54; i++){
            order_final[a[i]] = order_init[i];
        }
        for(i = 0; i < 54; i++){
            order_init[i] = order_final[i];
        }
    }
    // 按顺序输出
    for(i = 0; i < 54; i++){
        j = order_final[i];
        switch(j/13){
            case 0:
                ch = 'S';
                break;
            case 1:
                ch = 'H';
                break;
            case 2:
                ch = 'C';
                break;
            case 3:
                ch = 'D';
                break;
            case 4:
                ch = 'J';
                break;
            default:
                break;
        }
        sprintf(ch1, "%d", j%13+1);
        sprintf(temp, "%c", ch); 
        strcat(temp, ch1);
        printf("%s", temp);
        if(i != 53){
            printf(" ");
        }
    }
    

    return 0;
}
原文地址:https://www.cnblogs.com/baichangfu/p/7153567.html