HDU1712ACboy needs your help【分组背包】

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6249    Accepted Submission(s): 3430


Problem Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?

 

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.

 

 

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

 

 

Sample Input

2 2

1 2

1 3

2 2

2 1

2 1

2 3

3 2 1

3 2 1

0 0

 

 

Sample Output

3

4

6

 

题意:

给你一个n*m的矩阵,行代表第i门课程,列代表修这门课程要花的时间天数,矩阵值代表得到的效益,输出最大效益。

输入:

输入n,m后输入n行m列的数代表效益

 

#include <iostream>
#include <cstring>
using namespace std;
int n,m;
int a[111][111];
int f[111];
int main()
{
    while(cin>>n>>m)
    {
        if(n==0&&m==0)
            break;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                cin>>a[i][j];
        memset(f,0,sizeof(f));
        for(int i=1;i<=n;i++)
            for(int j=m;j>=0;j--)
                for(int k=1;k<=j;k++)
                    f[j]=max(f[j],f[j-k]+a[i][k]);
        cout<<f[m]<<endl;
    }
    return 0;
}
View Code

 

 

原文地址:https://www.cnblogs.com/asuml/p/5732073.html