Least Common Multiple

描述

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

输入

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

输出

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

样例输入

 2
3 5 7 15
6 4 10296 936 1287 792 1

样例输出

 105
10296

#include <iostream>
using namespace std;
int maxys(int n,int m)
{
    int h;
    while(m!=0)
    {
        h=n%m;
        n=m;
        m=h;
    }
    return n;
}
int main()
{
    int a,b,k,h,t;
    cin>>t;
    while(t--)
    {
        cin>>a>>b;
        k=b;
        for(int i=1;i<a;i++)
        {
            cin>>b;
            if(k<b)
            {
                h=k;k=b;b=h;
            }
            k=k/maxys(k,b)*b;
        }
        cout<<k<<endl;
    }
 }

 

原文地址:https://www.cnblogs.com/andrew3/p/8620030.html