HDOJ-三部曲一(搜索、数学)-1003-Curling 2.0

Curling 2.0

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 22   Accepted Submission(s) : 10
Problem Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.

Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.

Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).

Fig. 3: The solution for Fig. D-1 and the final board configuration

 
Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board First row of the board ... h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position

The dataset for Fig. D-1 is as follows:

6 6 1 0 0 2 1 0 1 1 0 0 0 0 0 0 0 0 0 3 0 0 0 0 0 0 1 0 0 0 0 1 0 1 1 1 1 1

 
Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

 
Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0
 
Sample Output
1
4
-1
4
10
-1
 
Source
PKU
 
 
 
 
这道题花了很长时间,原先看到求最短的走法就以为BFS,但发现没有办法压缩状态,后来看了POJ的Discuss才知道要DFS,原来DFS也可是求最短路径。
这题的模拟也很让我头疼。总算写出来了却TLE,后来和别人的代码一对照才知道step超过10时要剪枝。。。最后终于过了居然要157ms。。。。
 
 
#include<iostream>
#include<cstring>
using namespace std;


struct pos
{
	int x,y;
};

int w,h,Min,step=0;
pos p;
int board[101][101];

void DFS(pos p)
{
	int i;
	if(step>=10)                                     //step大于等于10时,不能走了,剪枝,回退
		return;
	if(p.x+1<h&&board[p.x+1][p.y]!=1)                //如果下一步不是石头,且不越界,就走试试看
	{
		step++;
		for(i=1;i<h-p.x&&board[i+p.x][p.y]!=1;i++)   //一步一步验证是否能到终点,是否碰到石头
		{
			if(board[i+p.x][p.y]==3)                 //到达终点,如果step比当前最小值小,保存step的值
			{
				if(Min>step)
					Min=step;
				step--;
				return;
			}
		}
		if(i<h-p.x)                                 //如果不划出边界
		{	
			board[i+p.x][p.y]=0;                    //碰到的石头变成空白
			p.x+=i-1;                               //移动到当前位置
			DFS(p);
			board[p.x+1][p.y]=1;
			p.x-=i-1;
		}
		step--;
	}
	if(p.x-1>=0&&board[p.x-1][p.y]!=1)
	{

		step++;
		for(i=1;i<=p.x&&board[p.x-i][p.y]!=1;i++)
		{
			if(board[p.x-i][p.y]==3)
			{
				if(Min>step)
					Min=step;
				step--;
				return;
			}	
		}
		if(i<=p.x)
		{	
			board[p.x-i][p.y]=0;
			p.x-=i-1;
			DFS(p);
			board[p.x-1][p.y]=1;
			p.x+=i-1;
		}
		step--;
	}
	if(p.y+1<w&&board[p.x][p.y+1]!=1)
	{
		step++;
		for(i=1;i<w-p.y&&board[p.x][p.y+i]!=1;i++)
		{
			if(board[p.x][p.y+i]==3)
			{
				if(Min>step)
					Min=step;
				step--;
				return;
			}
		}
		if(i<w-p.y)
		{	
			board[p.x][p.y+i]=0;
			p.y+=i-1;
			DFS(p);
			board[p.x][p.y+1]=1;
			p.y-=i-1;
		}
		step--;
	}
	if(p.y-1>=0&&board[p.x][p.y-1]!=1)
	{
		step++;
		for(i=1;i<=p.y&&board[p.x][p.y-i]!=1;i++)
		{
			if(board[p.x][p.y-i]==3)
			{
				if(Min>step)
					Min=step;
				step--;
				return;
			}
		}
		if(i<=p.y)
		{	
			board[p.x][p.y-i]=0;
			p.y-=i-1;
			DFS(p);
			board[p.x][p.y-1]=1;
			p.y+=i-1;
		}
		step--;
	}
	return;
}

int main()
{
	while(cin>>w>>h&&(w+h))
	{
		Min=11;
		int i,j;
		step=0;
		memset(board,0,sizeof(board));
		for(i=0;i<h;i++)
		{
			for(j=0;j<w;j++)
			{
				cin>>board[i][j];
				if(board[i][j]==2)
				{
					p.x=i;
					p.y=j;
				}
			}
		}
		DFS(p);
		if(Min==11)
			cout<<-1<<endl;
		else
			cout<<Min<<endl;

	}
}
 
原文地址:https://www.cnblogs.com/aljxy/p/3343569.html