POJ3104--Drying(Binary Search)

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2


这道题处理方法很不错。每分钟不放进烘干机会消耗1单位的水,而放进烘干机会消耗k。所以可以理解为,无论在哪都每分钟消耗1,而在烘干机里每分钟k-1。这样的话,问题就简化很多。

#include<iostream>
#include<numeric>
#include<algorithm>
using namespace std;
int clothes[100005];
int n,k;

bool C(int d){
    unsigned long long minutes=0;
    for(int i=0;i<n;i++){
        int remain=clothes[i]-d;
        if(remain>0){
            minutes+=(remain+k-1)/k;//ceil
            if(minutes>d)
                return false;
        }
    }
    return true;
}

int main(){
    cin>>n;
    for(int i=0;i<n;i++)
        cin>>clothes[i];
    cin>>k;
    k--;
    if(k==0){
        cout<<*max_element(clothes,clothes+n)<<endl;
        return 0;
    }
    int lb=*min_element(clothes,clothes+n)/k;
    int ub=*max_element(clothes,clothes+n);
    while(ub-lb>1){
        int mid=(ub+lb)/2;
        if(C(mid))
            ub=mid;
        else
            lb=mid;
    }
    cout<<ub<<endl;
    return 0;
}


原文地址:https://www.cnblogs.com/albert67/p/10399107.html