hihocoder#1631 : Cats and Fish

Description

There are many homeless cats in PKU campus. They are all happy because the students in the cat club of PKU take good care of them. Li lei is one of the members of the cat club. He loves those cats very much. Last week, he won a scholarship and he wanted to share his pleasure with cats. So he bought some really tasty fish to feed them, and watched them eating with great pleasure. At the same time, he found an interesting question:

There are m fish and n cats, and it takes ci minutes for the ith cat to eat out one fish. A cat starts to eat another fish (if it can get one) immediately after it has finished one fish. A cat never shares its fish with other cats. When there are not enough fish left, the cat which eats quicker has higher priority to get a fish than the cat which eats slower. All cats start eating at the same time. Li Lei wanted to know, after x minutes, how many fish would be left.

Input

There are no more than 20 test cases.

For each test case:

The first line contains 3 integers: above mentioned m, n and x (0 < m <= 5000, 1 <= n <= 100, 0 <= x <= 1000).

The second line contains n integers c1,c2 … cn,  ci means that it takes the ith cat ci minutes to eat out a fish ( 1<= ci <= 2000).

Output

For each test case, print 2 integers p and q, meaning that there are p complete fish(whole fish) and q incomplete fish left after x minutes.

Sample Input

2 1 1
1
8 3 5
1 3 4
4 5 1
5 4 3 2 1

Sample Output

1 0
0 1
0 3


用b记录每个猫的状态,正在吃鱼是1,否则是0
当当前的时间能被猫的吃鱼时间整除,就表示当前的猫吃完了一条鱼
用num表示吃完的鱼的条数,cnt表示剩的鱼的条数
#include <bits/stdc++.h>

using namespace std;
int a[105];
int b[105];
int main(){
    int m,n,x;
    while(cin>>m>>n>>x){
        memset(b,0,sizeof(b));
        for(int i=1;i<=n;i++){
            cin>>a[i];
        }
        sort(a+1,a+n+1);
        int num=0,cnt=m;
        for(int i=1;i<=x;i++){
            for(int j=1;j<=n;j++){
                if(b[j]==0){
                    cnt--;
                    b[j]=1;
                }
                if(i%a[j]==0&&b[j]==1){
                    b[j]=0;
                    num++;
                }
                if(cnt==0)
                    break;
            }
            if(cnt==0)
                break;
        }
        int ans=0;
        for(int i=1;i<=n;i++){
            if(b[i]==1)
                ans++;
        }
        cout<<m-num-ans<<' '<<ans<<endl;
    }    
}
原文地址:https://www.cnblogs.com/albert67/p/10384745.html