1045. Favorite Color Stripe (30) -LCS允许元素重复

题目如下:

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (<=200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (<=10000) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:
6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6
Sample Output:
7


这道题目,按照正常的思路求解,应该使用最长公共子序列算法LCS,但与常规的LCS有所差别,常规LCS是从两个序列中按索引递增顺序,不重复的选取最大公共子列,而现在的问题是在序列B中按照A中的元素顺序可重复的找出最大子列,这样说起来比较抽象,下面举个例子,对于序列:

A={2,3,1,5,6} B={2,2,4,1,5,5,6,3,1,1,5,6}

如果是常规的LCS,我们找到的子列将会是{2,3,1,5,6},因为B完全的包含了A(不必连续)

如果是可重复的LCS,我们完全可以选择{2,2,3,1,1,5,6},这便是变种的LCS。

对于常规的LCS(关于LCS的算法请参考算法导论390页15.4节),只有A[i] = B[j]时才让当前的最大子列长度为maxLen[i-1][j-1]+1,其他情况则取maxLen[i-1][j]或者maxLen[i][j-1]中的最大值,这样的算法只能不重复的找出子列,如果要考虑重复,应该修改算法,无论什么情况,都取maxLen[i-1][j-1]、maxLen[i-1][j]和maxLen[i][j-1]中的最大值,如果A[i]=B[j],则在最大值的基础上+1,这样就可以处理重复的情况了。

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <vector>

using namespace std;

int maxLen[201][10001] = {0};

int main()
{
    int N,M,L;
    cin >> N;
    cin >> M;
    vector<int> like(M+1);
    int num;
    for(int i = 1; i <= M; i++){
        scanf("%d",&num);
        like[i] = num;
    }
    cin >> L;
    vector<int> seq(L+1);
    for(int i = 1; i <= L; i++){
        scanf("%d",&num);
        seq[i] = num;
    }
    int max = 0;
    for(int m = 1; m <= M; m++){
        for(int n = 1; n <= L; n++){
            max = maxLen[m-1][n-1];
            if(max < maxLen[m-1][n]) max = maxLen[m-1][n];
            if(max < maxLen[m][n-1]) max = maxLen[m][n-1];
            if(like[m] == seq[n]){
                maxLen[m][n] = max + 1;
            }else{
                maxLen[m][n] = max;
            }
//            if(like[m] == seq[n]){
//                maxLen[m][n] = maxLen[m-1][n-1] + 1;
//            }else if(maxLen[m-1][n] >= maxLen[m][n-1]){
//                maxLen[m][n] = maxLen[m-1][n];
//            }else{
//                maxLen[m][n] = maxLen[m][n-1];
//            } 
        }
    }

    cout << maxLen[M][L] << endl;

    return 0;
}


原文地址:https://www.cnblogs.com/aiwz/p/6154137.html