1084. Broken Keyboard (20)

题目如下:

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:
7_This_is_a_test
_hs_s_a_es
Sample Output:
7TI



题目的实质就是从A字符串中找到所有B中没有的,然后输出,注意要把字母转为大写,并且重复的只输出一次,输出顺序为与从前到后探测到的顺序相同。

因为不区分大小写,所以我们使用一个map存储所有实际输出的字符,然后遍历期望的字符串,如果遍历到的字符是字母,先转为大写,然后去map查询,如果查不到则说明是要输出的,并且存储map,这样就保证了不重复输出,也满足了输出顺序和大写。

代码如下:

#include <iostream>
#include <string>
#include <map>
#include <stdio.h>

using namespace std;

int main()
{
    string wanner,input;
    cin >> wanner >> input;
    map<char,bool> inputMap;
    for(int i = 0; i < input.length(); i++){
        input[i] = isalpha(input[i]) ? toupper(input[i]) : input[i];
        inputMap[input[i]] = true;
    }
    for(int i = 0; i < wanner.length(); i++){
        char c = wanner[i];
        c = isalpha(c) ? toupper(c) : c;
        if(inputMap.find(c) == inputMap.end()){
            inputMap[c] = true;
            printf("%c",c);
        }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/aiwz/p/6154050.html