hdu 336

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5097    Accepted Submission(s): 2396


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 
Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 
Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 
Sample Input
1 4 abab
 
Sample Output
6
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<set>
#include<vector>
#include<queue>
#include<map>
#include<algorithm>
#include<cmath>
#include<stdlib.h>
#include<time.h>
using namespace std;
#define mmax 200000+10
int next[mmax],ans[mmax],n;
char p[mmax];
void get_next(){
    memset(next,0,sizeof(next));
    for(int i=1;i<n;i++){
        int j=i;
        while(j>0){
            j=next[j];
            if(p[i]==p[j]){
                next[i+1]=j+1;
                break;
            }
        }
    }
}
void solve(){
    int sum=0;
    memset(ans,0,sizeof(ans));
    for(int i=1;i<=n;i++){
        ans[i]=(ans[next[i]]+1)%10007;
        sum+=ans[i];
    }
    cout<<sum%10007<<endl;
}
int main(){
    int t;cin>>t;
    while(t--){
        scanf("%d",&n);
        scanf("%s",p);
        get_next();
        solve();
    }
}
 
 
原文地址:https://www.cnblogs.com/ainixu1314/p/4146939.html