九度OnlineJudge之1464:Hello World for U

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h    d
e     l
l      r
lowo


That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入:

There are multiple test cases.Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出:

For each test case, print the input string in the shape of U as specified in the description.

样例输入:
helloworld!
ac.jobdu.com
样例输出:
h   !
e   d
l   l
lowor
a    m
c    o
.    c
jobdu.
#include <iostream>
#include <string>
#include <string.h> 
using namespace std; 
  int main(){   
 char str[81];   
 while(cin>>str)    
{      
 int len = strlen(str); 
   int x = (len+2)/3;   
   for (int i=0;i<x-1;i++)  
   {          
 cout<<str[i]; 
   for (int j=x-1;j<(len-1-x);j++)          
 cout<<" ";   
        cout<<str[len-1-i];    
       cout<<endl;     
  }      
 for (int j=x-1;j<(len-1-(x-2));j++)        
   cout<<str[j];      
  cout<<endl;   
  }    
 //system("pause");  
  return 0;} 


原文地址:https://www.cnblogs.com/ainima/p/6331274.html