浙江大学PAT上机题解析之1015. Reversible Primes (20)

 

时间限制 
400 ms
内存限制 
32000 kB
代码长度限制 
16000 B
判题程序   
Standard
作者   
CHEN, Yue

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases.  Each case occupies a line which contains two integers N and D.  The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
//这道题一开始没看懂题意,还以为是把数字逆序判素数呢,后来才知道是进制转换和素数判断
#include <iostream>

using namespace std;

bool isPrime(int k)
{  
 if(k==0||k==1) return false;
 if(k==2||k==3) return true;
for(int i=2;i*i<=k;i++)
if(k%i==0) return false;
return true;    
}

long  getReverse(long n,int radix)
{
  long num=n%radix; 
  while((n/radix)!=0)
  {
     n/=radix;               
     num = num*radix + n%radix;              
  }
  
  return num;
}

int main()
{
    long num;
    int D;
    while(cin>>num)
    {
        if(num<0) break;
        cin>>D;    
                
      if(isPrime(num)) 
      {
                 
      long int N_v = getReverse(num,D);
               
        if(isPrime(N_v))
                      
       cout<<"Yes"<<endl;  
       else
       cout<<"No"<<endl;                      
      }
      else
      {
       cout<<"No"<<endl;   
      }                      
    }
  
//   system("PAUSE");
    return 0;
}

原文地址:https://www.cnblogs.com/ainima/p/6331269.html