POJ3614 Sunscreen 优先队列+贪心

Description

  To avoid unsightly burns while tanning, each of the C (1 ≤ C ≤ 2500) cows must cover her hide with sunscreen when they're at the beach. Cow i has a minimum and maximum SPF rating (1 ≤ minSPFi ≤ 1,000; minSPFi ≤ maxSPFi ≤ 1,000) that will work. If the SPF rating is too low, the cow suffers sunburn; if the SPF rating is too high, the cow doesn't tan at all........

  The cows have a picnic basket with L (1 ≤ L ≤ 2500) bottles of sunscreen lotion, each bottle i with an SPF rating SPFi (1 ≤ SPFi ≤ 1,000). Lotion bottle i can cover coveri cows with lotion. A cow may lotion from only one bottle.

  What is the maximum number of cows that can protect themselves while tanning given the available lotions?

Input

  * Line 1: Two space-separated integers: C and L
  * Lines 2..C+1: Line i describes cow i's lotion requires with two integers: minSPFi and maxSPFi 
  * Lines C+2..C+L+1: Line i+C+1 describes a sunscreen lotion bottle i with space-separated integers: SPFi and coveri

Output

  A single line with an integer that is the maximum number of cows that can be protected while tanning

Sample

Sample Input

3 2
3 10
2 5
1 5
6 2
4 1
Sample Output

2

题意:

  有C个奶牛去晒太阳 (1 <=C <= 2500),每个奶牛各自能够忍受的阳光强度有一个最小值和一个最大值,太大太小都没有作用。

  而刚开始的阳光的强度非常大,奶牛都承受不住,然后奶牛就得涂抹防晒霜,防晒霜的作用是让阳光照在身上的阳光强度固定为某个值。

  那么为了不让奶牛烫伤,又不会没有效果。

  给出了L种防晒霜。每种的数量和固定的阳光强度也给出来了

  每个奶牛只能抹一瓶防晒霜,最后问能够享受晒太阳的奶牛有几个。

思路:

  防晒霜从小到大排序

  奶牛能承受的最小值从小到大排序

  从最小的防晒霜枚举,将所有符合最小值小于等于该防晒霜的奶牛的最大值放入优先队列之中。

  然后优先队列是小值先出

  因为把牛能承受的最小值从小到大排序后,牛能承受的最大值越小,则这只牛能选择的防晒霜的种类越受限,也就是说如果一只牛能承受1-3,另一只能承受1-5,有一个2的防晒霜,则这个防嗮爽优先给能承受1-3的使用。

  所以就可以将这些最大值中的最小的取出来

代码:

#include<stdio.h>
#include<stack>
#include<algorithm>
#include<queue>
#include<iostream>
#include<string.h>
#include<string>
using namespace std;
struct node
{
    int begin;
    int end;
} cow[2501];
struct node1
{
    int number;
    int spf;
} l[2501];
bool cmp(struct node a,struct node b)
{
     return a.begin<b.begin;
}
bool cmp1(struct node1 a,struct node1 b)
{
    return a.spf<b.spf;
}
int main()
{
    int m,n,logo=0;
    scanf("%d%d",&m,&n);
    for(int i=0; i<m; i++)
        scanf("%d%d",&cow[i].begin,&cow[i].end);
    // cin>>cow[i].begin>>cow[i].end;
    for(int i=0; i<n; i++)
        scanf("%d%d",&l[i].spf,&l[i].number);
    //cin>>l[i].spf>>l[i].number;
    sort(l,l+n,cmp1);//将防晒霜从小到大排序
    sort(cow,cow+m,cmp);//将牛能承受的最小值从小到大排序
    priority_queue<int, vector<int>,greater<int> >q;//存储牛能承受的防晒霜的最大值
    int ans=0,j=0;
    for(int i=0; i<n; i++)//枚举防晒霜
    {
        while(j<m&&cow[j].begin<=l[i].spf)//如果牛能承受的最小值小于防晒霜的值,将牛能承受的最大值入优先队列
        {
                q.push(cow[j].end);
                j++;
        }
        while(!q.empty()&&l[i].number)//从小到大出队,将防晒霜给牛用,直到这种防晒霜用完。
        {
            int cnt=q.top();
            q.pop();
            if(cnt>=l[i].spf)
            {
                ans++;
                l[i].number--;
            }
        }
    }
    printf("%d",ans);
    //cout<<ans;

}
/*
5 3
3 10
2 5
4 8
4 6
3 5
7 1
9 1
6 2
*/

  

原文地址:https://www.cnblogs.com/aiguona/p/7218072.html